aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/swig
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-06 09:59:43 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-06 09:59:43 +0200
commit75c6eb25b4bd16c0d81ee7af405c8f090db752e1 (patch)
tree1a1063379839b6470f4583f66a0c19ce4e7679e9 /recipes/swig
parentbf1fa81a797de0d05bc0f3b3f8f96eeba6ece76c (diff)
downloadopenembedded-75c6eb25b4bd16c0d81ee7af405c8f090db752e1.tar.gz
swig: update to 1.3.39
Diffstat (limited to 'recipes/swig')
-rw-r--r--recipes/swig/swig-native_1.3.39.bb7
-rw-r--r--recipes/swig/swig_1.3.39.bb16
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes/swig/swig-native_1.3.39.bb b/recipes/swig/swig-native_1.3.39.bb
new file mode 100644
index 0000000000..8210bb9cfb
--- /dev/null
+++ b/recipes/swig/swig-native_1.3.39.bb
@@ -0,0 +1,7 @@
+require swig_${PV}.bb
+inherit native
+
+do_stage() {
+ oe_runmake install PREFIX=${STAGING_BINDIR}/..
+}
+
diff --git a/recipes/swig/swig_1.3.39.bb b/recipes/swig/swig_1.3.39.bb
new file mode 100644
index 0000000000..8a8138c21c
--- /dev/null
+++ b/recipes/swig/swig_1.3.39.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "SWIG - Simplified Wrapper and Interface Generator"
+HOMEPAGE = "http://swig.sourceforge.net/"
+LICENSE = "BSD"
+SECTION = "devel"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/swig/swig-${PV}.tar.gz"
+S = "${WORKDIR}/swig-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-python=${STAGING_BINDIR_NATIVE} --with-swiglibdir=${STAGING_DIR_NATIVE}/swig"
+
+do_configure() {
+ oe_runconf
+}
+