aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/system-config-printer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-04-28 18:56:54 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:15:14 -0300
commit57c5f8879e63e9d1e53552edf258f56a9ce1a2b2 (patch)
treedc7b1964c3a644d4f89aed838f1b357b31be2e1c /recipes/system-config-printer
parented4f8aa703d1f93178837c3c52f82b916a7160ac (diff)
downloadopenembedded-57c5f8879e63e9d1e53552edf258f56a9ce1a2b2.tar.gz
system-config-printer: add to provide python-cupshelpers to hal-cups-utils
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/system-config-printer')
-rw-r--r--recipes/system-config-printer/system-config-printer_1.1.7.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/system-config-printer/system-config-printer_1.1.7.bb b/recipes/system-config-printer/system-config-printer_1.1.7.bb
new file mode 100644
index 0000000000..5a6d6320ac
--- /dev/null
+++ b/recipes/system-config-printer/system-config-printer_1.1.7.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "cups Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "cups"
+RDEPENDS_python-cupshelpers += "python-pprint python-netclient python-misc"
+PR = "r2"
+
+SRC_URI = "http://cyberelk.net/tim/data/${PN}/1.1/${PN}-${PV}.tar.bz2"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ # disable xmlto usage since we won't use manpages
+ sed -i 's,xmlto,echo xmlto,g' ${S}/Makefile*
+}
+
+PACKAGES += "python-cupshelpers"
+
+FILES_${PN} = "" # we're not going to support it for now
+FILES_python-cupshelpers = "${libdir}"