summaryrefslogtreecommitdiffstats
path: root/recipes/taglib/taglib_1.5.bb
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2009-03-24 14:35:04 +0100
committerwoglinde <heinold@inf.fu-berlin.de>2009-03-29 00:28:31 +0100
commit51d9060d45df468015a42e0a37d837c1b906e63b (patch)
tree2309b4628d7322aad07e662ef0b7ac0c72c787f0 /recipes/taglib/taglib_1.5.bb
parent7b383197a2d1b8730f2cee59ce5ab418277b8af4 (diff)
downloadopenembedded-51d9060d45df468015a42e0a37d837c1b906e63b.tar.gz
taglib: update to version 1.5 and using cmake for build
Diffstat (limited to 'recipes/taglib/taglib_1.5.bb')
-rw-r--r--recipes/taglib/taglib_1.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/taglib/taglib_1.5.bb b/recipes/taglib/taglib_1.5.bb
new file mode 100644
index 0000000000..f67660faf1
--- /dev/null
+++ b/recipes/taglib/taglib_1.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
+SECTION = "libs/multimedia"
+HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
+ file://add_missing_exports_fix.diff;patch=1 \
+ file://gcc_visibility_feature.diff;patch=1 \
+ file://link_interface_libraries_fix.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/taglib-${PV}"
+
+inherit cmake pkgconfig binconfig
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/${PN}
+ install -m 0644 ${D}/usr/include/${PN}/*.h ${STAGING_INCDIR}/${PN}
+ oe_libinstall -C ${PN} -so libtag ${STAGING_LIBDIR}
+}
+
+LEAD_SONAME = "libtag.so.1"
+
+PACKAGES =+ "${PN}-c"
+
+FILES_${PN} = "${libdir}/libtag.so.*"
+FILES_${PN}-c = "${libdir}/libtag_c.so.*"