aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tango
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-27 20:53:05 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-28 10:16:27 +0100
commita71f287b6f15da6e91d31dc89bc49be183535516 (patch)
treeb4907fc0df6df5a69c29135bc14059a2826072e8 /recipes/tango
parent25e876d130bfc84cfd1cbbc38372c7695ca2b586 (diff)
downloadopenembedded-a71f287b6f15da6e91d31dc89bc49be183535516.tar.gz
tango-icon-theme-enable: Add recipe for enable the icon theme once installed (hackish).
Diffstat (limited to 'recipes/tango')
-rw-r--r--recipes/tango/tango-icon-theme-enable.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/tango/tango-icon-theme-enable.bb b/recipes/tango/tango-icon-theme-enable.bb
new file mode 100644
index 0000000000..58ad5924f8
--- /dev/null
+++ b/recipes/tango/tango-icon-theme-enable.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Enable tango-icon-theme in gtkrc"
+
+RDEPENDS = "tango-icon-theme"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/gtk-2.0
+touch $D${sysconfdir}/gtk-2.0/gtkrc
+sed -i /gtk-icon-theme-name/d $D${sysconfdir}/gtk-2.0/gtkrc
+echo 'gtk-icon-theme-name = "Tango"' >> $D${sysconfdir}/gtk-2.0/gtkrc
+}