summaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-base.bb
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 08:17:55 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 08:17:55 +0100
commit49d5f70658ab0386bee5869656d0405a6d416e35 (patch)
treeeb05cb5f3f5f6dcb3510032d1e8843823660d04a /recipes/tasks/task-base.bb
parenta5f31b42d1dbdeb252b73cf0dd260d94de8bb4e9 (diff)
downloadopenembedded-49d5f70658ab0386bee5869656d0405a6d416e35.tar.gz
task-base: Introduce DISTRO_apm and convert recipes to use it.
* This allows distros to override the apm provider with an DISTRO_apm variable * The change should be transparent and invisible for other distros * This could also be done with a virtual/apm package, and a PREFERED_PROVIDER set to apm Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'recipes/tasks/task-base.bb')
-rw-r--r--recipes/tasks/task-base.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index ed561b802e..6aad8730e2 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r86"
+PR = "r87"
inherit task
@@ -60,6 +60,9 @@ HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24", "linux-hotplug",""
#
DISTRO_SSH_DAEMON ?= "dropbear"
+# Distro can override apm provider
+DISTRO_apm ?= "apm"
+
#
# bluetooth manager
#
@@ -190,7 +193,7 @@ RDEPENDS_task-base-acpi = "\
acpid"
RDEPENDS_task-base-apm = "\
- apm \
+ "${DISTRO_apm}" \
apmd \
${@base_contains('MACHINE_FEATURES', 'kernel24', 'network-suspend-scripts', '',d)}"