summaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-base.bb
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-02-08 11:14:33 +0000
committerKhem Raj <raj.khem@gmail.com>2010-02-10 12:52:38 -0800
commitf4b798241eca0ea18a31f9e87a40f440df2d9fde (patch)
treedaeaf8249fde80c8164055653f73cb0d8a042402 /recipes/tasks/task-base.bb
parentf08176b50a59f9eeac6d4dee7af0cd937a19e05c (diff)
downloadopenembedded-f4b798241eca0ea18a31f9e87a40f440df2d9fde.tar.gz
task-base.bb: use uniform test for set
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/tasks/task-base.bb')
-rw-r--r--recipes/tasks/task-base.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index d59acba026..fc04b46ff5 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -136,7 +136,9 @@ python __anonymous () {
import bb
- if not hasattr(__builtins__, 'set'):
+ try:
+ set
+ except NameError:
from sets import Set as set
distro_features = set(bb.data.getVar("DISTRO_FEATURES", d, 1).split())