aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-fso-toolchain-target.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tasks/task-fso-toolchain-target.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tasks/task-fso-toolchain-target.bb')
-rw-r--r--recipes/tasks/task-fso-toolchain-target.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes/tasks/task-fso-toolchain-target.bb b/recipes/tasks/task-fso-toolchain-target.bb
new file mode 100644
index 0000000000..d042849bed
--- /dev/null
+++ b/recipes/tasks/task-fso-toolchain-target.bb
@@ -0,0 +1,69 @@
+DESCRIPTION = "Packages for a standalone SDK or external toolchain"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r1"
+
+PACKAGES = "${PN}"
+
+# Stuff contained in this SDK is largely taken from task-sdk-base.bb.
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for an FSO image.
+# Also feel free to remove stuff that's silly. And someone should
+# review the glibc-gconv list to see if that makes sense.
+
+RDEPENDS_${PN} = "\
+ glibc \
+ glibc-dbg \
+ glibc-dev \
+ glibc-utils \
+ libsegfault \
+ glibc-thread-db \
+ glibc-localedata-i18n \
+ glibc-gconv-ibm850 \
+ glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-1 \
+ glibc-gconv-iso8859-15 \
+ locale-base-en-gb \
+ libgcc \
+ libstdc++ \
+ linux-libc-headers-dev \
+ \
+ libssl \
+ libcrypto \
+ openssl-dev \
+ libts-dev \
+ ncurses-dev \
+ readline-dev \
+ gnutls-dev \
+ libgcrypt-dev \
+ libapm-dev \
+ alsa-dev \
+ alsa-lib-dev \
+ libgpg-error-dev \
+ libx11-dev \
+ util-macros-dev \
+ bigreqsproto-dev \
+ xproto-dev \
+ xextproto-dev \
+ xtrans-dev \
+ xcmiscproto-dev \
+ xf86bigfontproto-dev \
+ kbproto-dev \
+ inputproto-dev \
+ glib-2.0-dev \
+ expat-dev \
+ libice-dev \
+ libsm-dev \
+ dbus-dev \
+ bluez-libs-dev \
+ jpeg-dev \
+ libpng-dev \
+ "
+
+# This one needs further investigation; seems to be some
+# sort of naming problem that breaks the SDK when it is
+# added directly.
+ODDLY_BROKEN_PACKAGES ="\
+ libz-dev \
+"