aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2010-06-22 07:09:23 -0400
committerPhilip Balister <philip@balister.org>2010-06-22 07:09:23 -0400
commit978dee15134ae637dbe37f28ed684c246956f5a1 (patch)
tree5beb67e89474ade105b6b805d51c9fb70fbb6cb7 /recipes/tasks
parentd2d2a6cb05fd2790f8c7b8f6cfc9ba85fbc29319 (diff)
downloadopenembedded-978dee15134ae637dbe37f28ed684c246956f5a1.tar.gz
task-sdk-gnuradio-native : Add a SDK for building GNU Radio natively on devices.
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-sdk-gnuradio-native.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/tasks/task-sdk-gnuradio-native.bb b/recipes/tasks/task-sdk-gnuradio-native.bb
new file mode 100644
index 0000000000..3b8bdeee55
--- /dev/null
+++ b/recipes/tasks/task-sdk-gnuradio-native.bb
@@ -0,0 +1,21 @@
+require task-sdk-native.inc
+
+DEPENDS += "libusb1 guile fftw python alsa-lib jack boost cppunit sdcc swig \
+ python python-numpy git util-linux-ng gsl python-cheetah git"
+
+RDEPENDS += "libusb1-dev guile-dev fftwf-dev alsa-dev alsa-lib-dev jack-dev \
+ cppunit-dev swig python-devel python-numpy-dev python-textutils \
+ python-distutils python-re python-stringold python-lang \
+ python-threading python-unittest python-shell python-pickle \
+ python-pprint python-compiler python-pkgutil python-pydoc \
+ python-mmap python-netclient python-difflib python-compile \
+ python-cheetah \
+ boost-dev gsl-dev sdcc git util-linux-ng util-linux-ng-swaponoff"
+
+RPROVIDES_${PN} = "task-native-gnuradio-sdk"
+
+PR = "${INC_PR}.10"
+
+ALLOW_EMPTY = "1"
+PACKAGES = "${PN}"
+