aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-02-03 14:18:52 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:16 +0200
commit9b029223ef6d0a82a61eaeefca0892e4602a77ce (patch)
tree3a595d941ce41715bdbd3b2e4aacd5a4b8963efa /recipes/tasks
parentc85386fccb05a18583ca40bffdeccfcb55780359 (diff)
downloadopenembedded-9b029223ef6d0a82a61eaeefca0892e4602a77ce.tar.gz
meta-toolchain-dvsdk: replace with arago version
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-arago-toolchain-dvsdk-host.bb78
-rw-r--r--recipes/tasks/task-arago-toolchain-dvsdk-target.bb15
-rw-r--r--recipes/tasks/task-arago-toolchain-gst-host.bb11
-rw-r--r--recipes/tasks/task-arago-toolchain-gst-target.bb16
-rw-r--r--recipes/tasks/task-arago-toolchain-host.bb13
-rw-r--r--recipes/tasks/task-arago-toolchain-target.bb35
6 files changed, 168 insertions, 0 deletions
diff --git a/recipes/tasks/task-arago-toolchain-dvsdk-host.bb b/recipes/tasks/task-arago-toolchain-dvsdk-host.bb
new file mode 100644
index 0000000000..71b0faca62
--- /dev/null
+++ b/recipes/tasks/task-arago-toolchain-dvsdk-host.bb
@@ -0,0 +1,78 @@
+DESCRIPTION = "Host packages for a standalone Arago SDK or external toolchain"
+PR = "r18"
+ALLOW_EMPTY = "1"
+
+inherit sdk
+
+PACKAGES = "${PN}"
+
+DVSDK_HOST_PACKAGE = "\
+ ti-xdctools-sdk \
+ ti-xdais-sdk \
+ ti-codecs-dm365-sdk \
+ ti-codecs-dm355-sdk \
+ ti-dm365mm-module-sdk \
+ ti-codec-engine-sdk \
+ ti-framework-components-sdk \
+ ti-linuxutils-sdk \
+ ti-dmai-sdk \
+ ti-dvsdk-demos-sdk \
+ "
+
+DVSDK_HOST_PACKAGE_dm6446-evm = "\
+ ti-codec-engine-sdk \
+ ti-codec-combo-dm6446-sdk \
+ ti-xdctools-sdk \
+ ti-dmai-sdk \
+ ti-dspbios-sdk \
+ ti-cgt6x-sdk \
+ "
+
+DVSDK_HOST_PACKAGE_dm6467-evm = "\
+ ti-codec-engine-sdk \
+ ti-codec-combo-dm6467-sdk \
+ ti-xdctools-sdk \
+ ti-dmai-sdk \
+ ti-dspbios-sdk \
+ ti-cgt6x-sdk \
+ "
+
+DVSDK_HOST_PACKAGE_dm6467t-evm = "\
+ ti-dspbios-sdk \
+ ti-dspbiosutils-sdk \
+ ti-codec-engine-sdk \
+ ti-dmai-sdk \
+ ti-dsplink-module-sdk \
+ ti-dvsdk-demos-sdk \
+ ti-edma3-lld-sdk \
+ ti-framework-components-sdk \
+ ti-linuxutils-sdk \
+ ti-codec-combo-dm6467-sdk \
+ ti-xdais-sdk \
+ ti-xdctools-sdk \
+ ti-cgt6x-sdk \
+ "
+
+DVSDK_HOST_PACKAGE_omap3evm = "\
+ ti-codec-engine-sdk \
+ ti-codec-combo-omap3530-sdk \
+ ti-xdctools-sdk \
+ ti-dmai-sdk \
+ ti-dspbios-sdk \
+ ti-cgt6x-sdk \
+ "
+
+DVSDK_HOST_PACKAGE_beagleboard = "\
+ ti-codec-engine-sdk \
+ ti-codec-combo-omap3530-sdk \
+ ti-xdctools-sdk \
+ ti-dmai-sdk \
+ ti-dspbios-sdk \
+ ti-cgt6x-sdk \
+ "
+
+RDEPENDS_${PN} = "\
+ task-arago-toolchain-host \
+ ${DVSDK_HOST_PACKAGE} \
+ ti-legacy-dvsdk \
+ "
diff --git a/recipes/tasks/task-arago-toolchain-dvsdk-target.bb b/recipes/tasks/task-arago-toolchain-dvsdk-target.bb
new file mode 100644
index 0000000000..c14325547a
--- /dev/null
+++ b/recipes/tasks/task-arago-toolchain-dvsdk-target.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Target packages for a standalone Arago SDK or external toolchain"
+ALLOW_EMPTY = "1"
+PR = "r18"
+
+PACKAGES = "${PN}"
+
+# Stuff contained in this SDK is largely taken from task-sdk-base.bb.
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for a Arago image.
+# Also feel free to remove stuff that's silly.
+
+RDEPENDS_${PN} = "\
+ task-arago-toolchain-target \
+# kernel-source \
+ "
diff --git a/recipes/tasks/task-arago-toolchain-gst-host.bb b/recipes/tasks/task-arago-toolchain-gst-host.bb
new file mode 100644
index 0000000000..5bb5531027
--- /dev/null
+++ b/recipes/tasks/task-arago-toolchain-gst-host.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Host packages for a standalone Arago SDK or external toolchain"
+PR = "r15"
+ALLOW_EMPTY = "1"
+
+inherit sdk
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+ task-arago-toolchain-dvsdk-host \
+ "
diff --git a/recipes/tasks/task-arago-toolchain-gst-target.bb b/recipes/tasks/task-arago-toolchain-gst-target.bb
new file mode 100644
index 0000000000..3c6c2b9538
--- /dev/null
+++ b/recipes/tasks/task-arago-toolchain-gst-target.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Target packages for a standalone Arago SDK or external toolchain"
+ALLOW_EMPTY = "1"
+PR = "r24"
+
+PACKAGES = "${PN}"
+
+# Stuff contained in this SDK is largely taken from task-sdk-base.bb.
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for a Arago image.
+# Also feel free to remove stuff that's silly.
+
+RDEPENDS_${PN} = "\
+ task-arago-toolchain-dvsdk-target \
+ gstreamer-dev \
+ gstreamer-ti-dev \
+ "
diff --git a/recipes/tasks/task-arago-toolchain-host.bb b/recipes/tasks/task-arago-toolchain-host.bb
new file mode 100644
index 0000000000..ec944b68cd
--- /dev/null
+++ b/recipes/tasks/task-arago-toolchain-host.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Host packages for a standalone Arago SDK or external toolchain"
+PR = "r3"
+ALLOW_EMPTY = "1"
+
+inherit sdk
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+ pkgconfig-sdk \
+ opkg-sdk \
+ libtool-sdk \
+ "
diff --git a/recipes/tasks/task-arago-toolchain-target.bb b/recipes/tasks/task-arago-toolchain-target.bb
new file mode 100644
index 0000000000..e22ac2be03
--- /dev/null
+++ b/recipes/tasks/task-arago-toolchain-target.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Target packages for a standalone Arago SDK or external toolchain"
+ALLOW_EMPTY = "1"
+PR = "r2"
+
+PACKAGES = "${PN}"
+
+# Stuff contained in this SDK is largely taken from task-sdk-base.bb.
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for a Arago image.
+# Also feel free to remove stuff that's silly.
+
+RDEPENDS_${PN} = "\
+ alsa-dev \
+ alsa-lib-dev \
+ alsa-utils-dev \
+ curl-dev \
+ e2fsprogs-libs-dev \
+ i2c-tools-dev \
+ freetype-dev \
+ jpeg-dev \
+ lzo-dev \
+ libopkg-dev \
+ libpng-dev \
+ libpng12-dev \
+ readline-dev \
+ libts-dev \
+ libusb-compat-dev \
+ libusb1-dev \
+ libvolume-id-dev \
+ zlib-dev \
+ mtd-utils-dev \
+ ncurses-dev \
+ opkg-nogpg-dev \
+ sysvinit-dev \
+ "