aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-07-11 00:35:32 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-07-12 15:05:54 +0200
commite2e1cf695fa8577cd211506d9d0f0f575423472c (patch)
tree3139268c698313f3f82fa8bedcc5a01c89f3be94 /recipes/tasks
parent41c81a78c33bbf173b5fceb231f747cf1a761776 (diff)
downloadopenembedded-e2e1cf695fa8577cd211506d9d0f0f575423472c.tar.gz
task-shr-minimal: fix case when binary locales generation is disabled
2 issues were present: *disabled was a string and so,when binary locales generation was disabled it never executed the return statement For fixing it,I've copied and adapted the glibc code that JaMa pointed me out: FreeNode-#oe.log:Jul 09 14:19:26 <JaMa> GNUtoo|laptop: glibc/glibc-package.inc is using "if enabled and int(enabled):" *return should return "",else the dependency of task-shr-minimal are "None". I also bumped PR
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-shr-minimal.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes/tasks/task-shr-minimal.bb b/recipes/tasks/task-shr-minimal.bb
index d4be115db1..6f82334896 100644
--- a/recipes/tasks/task-shr-minimal.bb
+++ b/recipes/tasks/task-shr-minimal.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Lite Image Feed"
-PR = "r31"
+PR = "r32"
PV = "2.0"
LICENSE = "GPL"
@@ -11,8 +11,8 @@ def get_rdepends(bb, d):
enabled = bb.data.getVar("ENABLE_BINARY_LOCALE_GENERATION", d, 1)
# If locale is disabled, bail out
- if not enabled:
- return
+ if not enabled or not int(enabled):
+ return ""
locales = bb.data.getVar("GLIBC_GENERATE_LOCALES", d, 1)
if not locales or locales == "all":