summaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-25 11:02:48 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-27 15:26:58 +0100
commit599bbb2eaff6f0827b04ab5b2665303a22ea072e (patch)
tree7690ca6aed080d1a4b8f816a1e300b8d3264b264 /recipes/tasks
parent6de8a003f930bfade8502cf80617009a9c96c278 (diff)
downloadopenembedded-599bbb2eaff6f0827b04ab5b2665303a22ea072e.tar.gz
XFCE: Import all the 4.6.1 recipes (and a newer version of xfce-terminal).
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-xfce46-base.bb32
-rw-r--r--recipes/tasks/task-xfce46-extras.bb39
2 files changed, 71 insertions, 0 deletions
diff --git a/recipes/tasks/task-xfce46-base.bb b/recipes/tasks/task-xfce46-base.bb
new file mode 100644
index 0000000000..430d048a7d
--- /dev/null
+++ b/recipes/tasks/task-xfce46-base.bb
@@ -0,0 +1,32 @@
+# task-xfce46-base
+
+DESCRIPTION = "All packages required for a base installation of XFCE 4.6.*"
+PR = "r1"
+
+inherit task
+
+RDEPENDS_${PN} = " \
+ xfwm4 \
+ xfwm4-theme-default \
+ xfce4-session \
+ xfconf \
+ xfdesktop \
+ xfce4-panel \
+ \
+ gtk-xfce-engine \
+ \
+ xfce-utils \
+ xfce4-panel-plugin-actions \
+ xfce4-panel-plugin-clock \
+ xfce4-panel-plugin-iconbox \
+ xfce4-panel-plugin-launcher \
+ xfce4-panel-plugin-pager \
+ xfce4-panel-plugin-separator \
+ xfce4-panel-plugin-showdesktop \
+ xfce4-panel-plugin-systray \
+ xfce4-panel-plugin-tasklist \
+ xfce4-panel-plugin-windowlist \
+ xfce4-settings \
+ xfce-terminal \
+ thunar \
+"
diff --git a/recipes/tasks/task-xfce46-extras.bb b/recipes/tasks/task-xfce46-extras.bb
new file mode 100644
index 0000000000..abbe3b0fdc
--- /dev/null
+++ b/recipes/tasks/task-xfce46-extras.bb
@@ -0,0 +1,39 @@
+# task-xfce46-extras
+
+DESCRIPTION = "Extra suggested packages to produce a recommended XFCE 4.6.* installation"
+PR = "r2"
+
+inherit task
+
+XFCE_THEMES = " \
+ xfwm4-theme-daloa \
+ xfwm4-theme-moheli \
+ xfwm4-theme-default-4.0 \
+ xfwm4-theme-default-4.2 \
+ xfwm4-theme-default-4.4 \
+ xfwm4-theme-katiola \
+ xfwm4-theme-kokodi \
+ xfwm4-theme-moheli \
+ xfwm4-theme-sassandra \
+ xfwm4-theme-stoneage \
+ xfwm4-theme-therapy \
+ xfwm4-theme-tyrex \
+ xfwm4-theme-wallis \
+"
+
+RDEPENDS_${PN} = " \
+ task-xfce46-base \
+ \
+ ${XFCE_THEMES} \
+ \
+ xfce4-notifyd \
+ xfce4-mixer \
+ xfce4-appfinder \
+ xfprint \
+ midori \
+ orage \
+ squeeze \
+ ristretto \
+ mousepad \
+ gigolo \
+"