summaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-09-03 18:44:01 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-09-03 18:44:01 +0200
commitbc6ce2f8b874b97b65ac8c6d61f0483bdf309565 (patch)
tree63418f2e681fca63394d1f1d35e5490eec2a08b5 /recipes/tasks
parent7b21597db945fef852e17e54c9d82dd727b6594e (diff)
downloadopenembedded-bc6ce2f8b874b97b65ac8c6d61f0483bdf309565.tar.gz
task-cli-tools[-python]: factor python-based cli tools out of common recipe to improve build time for those who don't need/want any of the python-based ones.
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-cli-tools-python.bb12
-rw-r--r--recipes/tasks/task-cli-tools.bb11
2 files changed, 15 insertions, 8 deletions
diff --git a/recipes/tasks/task-cli-tools-python.bb b/recipes/tasks/task-cli-tools-python.bb
new file mode 100644
index 0000000000..7c75084dd0
--- /dev/null
+++ b/recipes/tasks/task-cli-tools-python.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "A set of python-based command line tools"
+SECTION = "console"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r8"
+
+inherit task
+
+RDEPENDS_${PN} = "\
+ mickeydbus \
+ mickeyterm \
+"
diff --git a/recipes/tasks/task-cli-tools.bb b/recipes/tasks/task-cli-tools.bb
index e05fa398b7..0110a8d9b0 100644
--- a/recipes/tasks/task-cli-tools.bb
+++ b/recipes/tasks/task-cli-tools.bb
@@ -1,12 +1,12 @@
-DESCRIPTION = "A set of command line tools, python tools-based tools, debug tools"
+DESCRIPTION = "A set of command line tools useful for debugging"
SECTION = "console"
LICENSE = "MIT"
PV = "1.0"
-PR = "r7"
+PR = "r8"
inherit task
-PACKAGES += "${PN}-debug ${PN}-python"
+PACKAGES += "${PN}-debug"
RDEPENDS_${PN} = "\
dosfstools \
@@ -34,8 +34,3 @@ RDEPENDS_${PN}-debug = "\
s3c64xx-gpio \
strace \
"
-
-RDEPENDS_${PN}-python = "\
- mickeydbus \
- mickeyterm \
-"