aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcpdump
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tcpdump
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tcpdump')
-rw-r--r--recipes/tcpdump/files/0001-minimal-IEEE802.15.4-allowed.patch26
-rw-r--r--recipes/tcpdump/files/fix-paths.patch34
-rw-r--r--recipes/tcpdump/files/no-ipv6-tcpdump4.patch22
-rw-r--r--recipes/tcpdump/files/tcpdump_configure_no_-O2.patch36
-rw-r--r--recipes/tcpdump/tcpdump_3.9.7.bb20
-rw-r--r--recipes/tcpdump/tcpdump_4.0.0.bb25
6 files changed, 163 insertions, 0 deletions
diff --git a/recipes/tcpdump/files/0001-minimal-IEEE802.15.4-allowed.patch b/recipes/tcpdump/files/0001-minimal-IEEE802.15.4-allowed.patch
new file mode 100644
index 0000000000..f4358b5d49
--- /dev/null
+++ b/recipes/tcpdump/files/0001-minimal-IEEE802.15.4-allowed.patch
@@ -0,0 +1,26 @@
+From 9a6a3f37b6715fafb79fd88d2a2db3b49183226e Mon Sep 17 00:00:00 2001
+From: Sergey Lapin <slapin@slind.org>
+Date: Wed, 28 Jan 2009 16:34:15 +0300
+Subject: [PATCH] minimal IEEE802.15.4 allowed
+
+---
+ tcpdump.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/tcpdump.c b/tcpdump.c
+index ba8b702..0a88343 100644
+--- a/tcpdump.c
++++ b/tcpdump.c
+@@ -273,6 +273,9 @@ static struct printer printers[] = {
+ #ifdef DLT_MFR
+ { mfr_if_print, DLT_MFR },
+ #endif
++#ifdef DLT_IEEE802_15_4
++ { raw_if_print, DLT_IEEE802_15_4 },
++#endif
+ #if defined(DLT_BLUETOOTH_HCI_H4_WITH_PHDR) && defined(HAVE_PCAP_BLUETOOTH_H)
+ { bt_if_print, DLT_BLUETOOTH_HCI_H4_WITH_PHDR},
+ #endif
+--
+1.5.6.2
+
diff --git a/recipes/tcpdump/files/fix-paths.patch b/recipes/tcpdump/files/fix-paths.patch
new file mode 100644
index 0000000000..0cd321007a
--- /dev/null
+++ b/recipes/tcpdump/files/fix-paths.patch
@@ -0,0 +1,34 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- tcpdump-3.8.3/configure~fix-paths.patch
++++ tcpdump-3.8.3/configure
+@@ -8904,7 +8904,7 @@
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+- ac_lbl_cv_pcap_debug_defined=yes
++ ac_lbl_cv_pcap_debug_defined=no
+ else
+ echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
+@@ -8963,7 +8963,7 @@
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+- ac_lbl_cv_yydebug_defined=yes
++ ac_lbl_cv_yydebug_defined=no
+ else
+ echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
+@@ -9700,7 +9700,7 @@
+ echo $ECHO_N "checking for SSLeay... $ECHO_C" >&6
+ ac_cv_ssleay_path=no
+ incdir=no
+-for dir in /usr/${host_alias} /usr /usr/local /usr/local/ssl /usr/pkg; do
++for dir in /bla; do
+ #
+ # XXX - is there a better way to check if a given library is
+ # in a given directory than checking each of the possible
diff --git a/recipes/tcpdump/files/no-ipv6-tcpdump4.patch b/recipes/tcpdump/files/no-ipv6-tcpdump4.patch
new file mode 100644
index 0000000000..a399d0508f
--- /dev/null
+++ b/recipes/tcpdump/files/no-ipv6-tcpdump4.patch
@@ -0,0 +1,22 @@
+Compiling tcpdump 4.0.0 without ipv6 - linking against ipv6less
+libpcap too - generates the following error:
+
+print-enc.o: In function `enc_if_print':
+print-enc.c:(.text+0xce): undefined reference to `ip6_print'
+collect2: ld returned 1 exit status
+make: *** [tcpdump] Error 1
+
+--- tcpdump/print-enc.c.orig 2008-09-01 04:44:22 +0200
++++ tcpdump/print-enc.c 2008-11-11 14:48:00 +0100
+@@ -77,9 +77,11 @@
+ case AF_INET:
+ ip_print(gndo, p, length);
+ break;
++#ifdef INET6
+ case AF_INET6:
+ ip6_print(p, length);
+ break;
++#endif
+ }
+
+ out:
diff --git a/recipes/tcpdump/files/tcpdump_configure_no_-O2.patch b/recipes/tcpdump/files/tcpdump_configure_no_-O2.patch
new file mode 100644
index 0000000000..773fc52e54
--- /dev/null
+++ b/recipes/tcpdump/files/tcpdump_configure_no_-O2.patch
@@ -0,0 +1,36 @@
+--- tcpdump-3.8.3/configure 2004-03-28 23:06:09.000000000 +0200
++++ tcpdump-3.8.3.mod/configure 2004-07-29 13:04:18.450769088 +0200
+@@ -2059,13 +2059,13 @@
+ CFLAGS=$ac_save_CFLAGS
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-g"
+ else
+ CFLAGS="-g"
+ fi
+ else
+ if test "$GCC" = yes; then
+- CFLAGS="-O2"
++ CFLAGS=""
+ else
+ CFLAGS=
+ fi
+@@ -2291,7 +2291,7 @@
+ if test "$GCC" = yes ; then
+ if test "$SHLICC2" = yes ; then
+ ac_cv_lbl_gcc_vers=2
+- V_CCOPT="-O2"
++ V_CCOPT=""
+ else
+ echo "$as_me:$LINENO: checking gcc version" >&5
+ echo $ECHO_N "checking gcc version... $ECHO_C" >&6
+@@ -2308,7 +2308,7 @@
+ echo "$as_me:$LINENO: result: $ac_cv_lbl_gcc_vers" >&5
+ echo "${ECHO_T}$ac_cv_lbl_gcc_vers" >&6
+ if test $ac_cv_lbl_gcc_vers -gt 1 ; then
+- V_CCOPT="-O2"
++ V_CCOPT=""
+ fi
+ fi
+ else
diff --git a/recipes/tcpdump/tcpdump_3.9.7.bb b/recipes/tcpdump/tcpdump_3.9.7.bb
new file mode 100644
index 0000000000..ba9710d86a
--- /dev/null
+++ b/recipes/tcpdump/tcpdump_3.9.7.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A sophisticated network protocol analyzer"
+HOMEPAGE = "http://www.tcpdump.org/"
+LICENSE = "BSD"
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "libpcap"
+
+SRC_URI = "http://www.tcpdump.org/release/tcpdump-${PV}.tar.gz \
+ file://tcpdump_configure_no_-O2.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-crypto"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+ sed -i 's:/usr/lib:${STAGING_LIBDIR}:' ./Makefile
+ sed -i 's:/usr/include:${STAGING_INCDIR}:' ./Makefile
+}
diff --git a/recipes/tcpdump/tcpdump_4.0.0.bb b/recipes/tcpdump/tcpdump_4.0.0.bb
new file mode 100644
index 0000000000..537cb36aed
--- /dev/null
+++ b/recipes/tcpdump/tcpdump_4.0.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A sophisticated network protocol analyzer"
+HOMEPAGE = "http://www.tcpdump.org/"
+LICENSE = "BSD"
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "libpcap"
+PR = "r1"
+
+SRC_URI = "http://www.tcpdump.org/release/tcpdump-${PV}.tar.gz \
+ file://tcpdump_configure_no_-O2.patch;patch=1 \
+ file://no-ipv6-tcpdump4.patch;patch=1 \
+ file://0001-minimal-IEEE802.15.4-allowed.patch;patch=1"
+
+inherit autotools
+# ac_cv_linux_vers=${ac_cv_linux_vers=2}
+
+EXTRA_OECONF = "--without-crypto"
+
+do_configure() {
+ gnu-configize
+ autoconf
+ oe_runconf
+ sed -i 's:/usr/lib:${STAGING_LIBDIR}:' ./Makefile
+ sed -i 's:/usr/include:${STAGING_INCDIR}:' ./Makefile
+}