aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcptraceroute
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tcptraceroute
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tcptraceroute')
-rw-r--r--recipes/tcptraceroute/tcptraceroute-1.5beta6/configure.ac.patch118
-rw-r--r--recipes/tcptraceroute/tcptraceroute_1.5beta6.bb14
2 files changed, 132 insertions, 0 deletions
diff --git a/recipes/tcptraceroute/tcptraceroute-1.5beta6/configure.ac.patch b/recipes/tcptraceroute/tcptraceroute-1.5beta6/configure.ac.patch
new file mode 100644
index 0000000000..42a12e4eea
--- /dev/null
+++ b/recipes/tcptraceroute/tcptraceroute-1.5beta6/configure.ac.patch
@@ -0,0 +1,118 @@
+Remove the checks for the OS.
+They require running the compiled program which is not possible when
+cross complining.
+At this stage I believe all OE targets are linux, so it should be ok
+for now.
+
+--- tcptraceroute-1.5beta6/configure.ac 2005/11/15 04:41:51 1.1
++++ tcptraceroute-1.5beta6/configure.ac 2005/11/15 04:41:58
+@@ -146,94 +146,6 @@
+ AC_FUNC_VPRINTF
+ AC_CHECK_FUNCS([gettimeofday memset select socket strchr])
+
+-# Is this Solaris?
+-AC_MSG_CHECKING(for Solaris)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM( [], [
+-#if defined (__SVR4) && defined (__sun)
+- exit(0);
+-#else
+- exit(-1);
+-#endif
+- ])
+- ],[
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_SOLARIS], 1, [Is this a Solaris system?])
+- HAVE_SOLARIS=yes
+- ],[
+- AC_MSG_RESULT(no)
+- ])
+-
+-# Is this BSDI?
+-AC_MSG_CHECKING(for BSDI)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM( [], [
+-#if defined (__bsdi__)
+- exit(0);
+-#else
+- exit(-1);
+-#endif
+- ])
+- ],[
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_BSDI], 1, [Is this a BSDI system?])
+- HAVE_BSDI=yes
+- ],[
+- AC_MSG_RESULT(no)
+- ])
+-
+-# Is this NetBSD?
+-AC_MSG_CHECKING(for NetBSD)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM( [], [
+-#if defined (__NetBSD__)
+- exit(0);
+-#else
+- exit(-1);
+-#endif
+- ])
+- ],[
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_NETBSD], 1, [Is this a NetBSD system?])
+- HAVE_NETBSD=yes
+- ],[
+- AC_MSG_RESULT(no)
+- ])
+-
+-# Is this MacOS X?
+-AC_MSG_CHECKING(for MacOS X)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM( [], [
+-#if defined (__APPLE__) && defined (__MACH__)
+- exit(0);
+-#else
+- exit(-1);
+-#endif
+- ])
+- ],[
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([HAVE_MACOSX], 1, [Is this a MacOS X system?])
+- HAVE_MACOSX=yes
+- ],[
+- AC_MSG_RESULT(no)
+- ])
+-
+-# Handle --enable-noselect-default
+-AC_ARG_ENABLE(noselect-default,
+- AC_HELP_STRING([--enable-noselect-default], [default to not using select(2)]),
+- [
+- NOSELECT_DEFAULT=$enable_noselect_default
+- ], [
+- if test "$HAVE_MACOSX" = "yes"; then
+- NOSELECT_DEFAULT=yes
+- elif test "$HAVE_BSDI" = "yes"; then
+- NOSELECT_DEFAULT=yes
+- elif test "$HAVE_NETBSD" = "yes"; then
+- NOSELECT_DEFAULT=yes
+- else
+- NOSELECT_DEFAULT=no
+- fi
+- ])
+-if test "$NOSELECT_DEFAULT" = "yes"; then
+- AC_DEFINE(NOSELECT_DEFAULT, 1, [Use select(2) by default?])
+-fi
+-
+ # Handle --enable-track-default=IP|PORT
+ AC_ARG_ENABLE(track-default,
+ AC_HELP_STRING([--enable-track-default=PORT|ID], [default to tracking probes by PORT or ID]),
+@@ -245,13 +157,7 @@
+ else
+ AC_MSG_ERROR([valid arguments for --enable-track-default are PORT or ID])
+ fi
+- ], [
+- if test "$HAVE_SOLARIS" = "yes"; then
+- TRACK_DEFAULT=port
+- else
+- TRACK_DEFAULT=id
+- fi
+- ])
++ ], [])
+ if test "$TRACK_DEFAULT" = "port"; then
+ AC_DEFINE(TRACK_PORT_DEFAULT, 1, [Track ports by default])
+ fi
diff --git a/recipes/tcptraceroute/tcptraceroute_1.5beta6.bb b/recipes/tcptraceroute/tcptraceroute_1.5beta6.bb
new file mode 100644
index 0000000000..29b7830a26
--- /dev/null
+++ b/recipes/tcptraceroute/tcptraceroute_1.5beta6.bb
@@ -0,0 +1,14 @@
+SECTION = "console/network"
+DESCRIPTION = "A traceroute implementation that uses TCP packets. This \
+allows it to bypass a lot of firewalls that block the traditional ping \
+and traceroute packets."
+HOMEPAGE = "http://michael.toren.net/code/tcptraceroute/"
+LICENSE = "GPL"
+PRIORITY = "optional"
+DEPENDS = "libnet-1.1"
+PR = "r0"
+
+SRC_URI = "http://michael.toren.net/code/tcptraceroute/tcptraceroute-${PV}.tar.gz \
+ file://configure.ac.patch;patch=1"
+
+inherit autotools