aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcptrack
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tcptrack
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tcptrack')
-rw-r--r--recipes/tcptrack/tcptrack-1.1.2/macros.patch29
-rw-r--r--recipes/tcptrack/tcptrack_1.1.2.bb12
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes/tcptrack/tcptrack-1.1.2/macros.patch b/recipes/tcptrack/tcptrack-1.1.2/macros.patch
new file mode 100644
index 0000000000..05e7642086
--- /dev/null
+++ b/recipes/tcptrack/tcptrack-1.1.2/macros.patch
@@ -0,0 +1,29 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- /dev/null
++++ tcptrack-1.1.2/acinclude.m4
+@@ -0,0 +1,21 @@
++dnl FreeBSD -pthread check - Jonathan McDowell
++AC_DEFUN(AC_PTHREAD_FREEBSD,
++[AC_MSG_CHECKING([if we need -pthread for threads])
++AC_CACHE_VAL(ac_ldflag_pthread,
++[ac_save_LDFLAGS="$LDFLAGS"
++LDFLAGS="-pthread $LDFLAGS"
++AC_TRY_LINK(
++[
++char pthread_create();
++],
++pthread_create();,
++eval "ac_ldflag_pthread=yes",
++eval "ac_ldflag_pthread=no"),
++LIBS="$ac_save_LDFLAGS"
++])
++if eval "test \"`echo $ac_ldflag_pthread`\" = yes"; then
++ AC_MSG_RESULT(yes)
++else
++ AC_MSG_RESULT(no)
++fi
++])
diff --git a/recipes/tcptrack/tcptrack_1.1.2.bb b/recipes/tcptrack/tcptrack_1.1.2.bb
new file mode 100644
index 0000000000..edccba93ad
--- /dev/null
+++ b/recipes/tcptrack/tcptrack_1.1.2.bb
@@ -0,0 +1,12 @@
+SECTION = "console/network"
+DESCRIPTION = "tcptrack is a packet sniffer, which passively watches for \
+connections on a specified network interface, tracks their states, and lists \
+them in a manner similar to the Unix 'top' command."
+LICENSE = "LGPL"
+DEPENDS = "ncurses libpcap"
+
+SRC_URI = "http://www.rhythm.cx/~steve/devel/tcptrack/release/${PV}/source/tcptrack-${PV}.tar.gz \
+ file://macros.patch;patch=1"
+S = "${WORKDIR}/tcptrack-${PV}"
+
+inherit autotools