aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/teleport
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/teleport
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/teleport')
-rw-r--r--recipes/teleport/files/crypt.c158
-rw-r--r--recipes/teleport/files/fix-desktop.patch12
-rw-r--r--recipes/teleport/files/remove-tododb.patch12
-rw-r--r--recipes/teleport/teleport_0.33.bb12
-rw-r--r--recipes/teleport/teleport_0.34.bb5
5 files changed, 199 insertions, 0 deletions
diff --git a/recipes/teleport/files/crypt.c b/recipes/teleport/files/crypt.c
new file mode 100644
index 0000000000..359c5ee99a
--- /dev/null
+++ b/recipes/teleport/files/crypt.c
@@ -0,0 +1,158 @@
+/*
+ * Copyright (C) 2003 Philip Blundell <philb@gnu.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
+ */
+
+#include <stdlib.h>
+#include <string.h>
+#include <glib.h>
+#include <assert.h>
+
+#include "libdisplaymigration/auth.h"
+#include "libdisplaymigration/crypt.h"
+
+static gcry_mpi_t
+mpi_from_sexp (gcry_sexp_t r, char *tag)
+{
+ gcry_sexp_t s = gcry_sexp_find_token (r, tag, 0);
+ return gcry_sexp_nth_mpi (s, 1, GCRYMPI_FMT_USG);
+}
+
+static char *
+hex_from_mpi (gcry_mpi_t m)
+{
+ char *buf;
+ gcry_mpi_aprint (GCRYMPI_FMT_HEX, (void *)&buf, NULL, m);
+ return buf;
+}
+
+void
+displaymigration_crypt_create_hash (char *display, char *challenge, size_t len, char *result)
+{
+ size_t dlen = strlen (display);
+ gchar *buf = g_malloc (dlen + 1 + len);
+ strcpy (buf, display);
+ memcpy (buf + dlen + 1, challenge, len);
+ gcry_md_hash_buffer (GCRY_MD_SHA1, result, buf, len + dlen + 1);
+ g_free (buf);
+}
+
+static int
+do_encode_md (const unsigned char *digest, size_t digestlen, int algo,
+ unsigned int nbits, gcry_mpi_t *r_val)
+{
+ int nframe = (nbits+7) / 8;
+ unsigned char *frame;
+ int i, n;
+ unsigned char asn[100];
+ size_t asnlen;
+
+ asnlen = sizeof(asn);
+ if (gcry_md_algo_info (algo, GCRYCTL_GET_ASNOID, asn, &asnlen))
+ return -1;
+
+ if (digestlen + asnlen + 4 > nframe )
+ return -1;
+
+ /* We encode the MD in this way:
+ *
+ * 0 1 PAD(n bytes) 0 ASN(asnlen bytes) MD(len bytes)
+ *
+ * PAD consists of FF bytes.
+ */
+ frame = g_malloc (nframe);
+ n = 0;
+ frame[n++] = 0;
+ frame[n++] = 1; /* block type */
+ i = nframe - digestlen - asnlen -3 ;
+ assert ( i > 1 );
+ memset ( frame+n, 0xff, i ); n += i;
+ frame[n++] = 0;
+ memcpy ( frame+n, asn, asnlen ); n += asnlen;
+ memcpy ( frame+n, digest, digestlen ); n += digestlen;
+ assert ( n == nframe );
+
+ gcry_mpi_scan (r_val, GCRYMPI_FMT_USG, frame, nframe, &nframe);
+ g_free (frame);
+ return 0;
+}
+
+gboolean
+displaymigration_crypt_sign_hash (struct rsa_key *k, char *hash, gchar **result)
+{
+ gcry_mpi_t mpi;
+ gcry_sexp_t data, sig, key;
+ int rc;
+ char *hex;
+
+ do_encode_md (hash, 20, GCRY_MD_SHA1, 1024, &mpi);
+
+ if (gcry_sexp_build (&data, NULL, "(data (value %m))", mpi))
+ return FALSE;
+
+ gcry_mpi_release (mpi);
+
+ if (gcry_sexp_build (&key, NULL, "(private-key (rsa (n %m) (e %m) (d %m) (p %m) (q %m) (u %m)))",
+ k->n, k->e, k->d, k->p, k->q, k->u))
+ {
+ gcry_sexp_release (data);
+ return FALSE;
+ }
+
+ rc = gcry_pk_sign (&sig, data, key);
+
+ gcry_sexp_release (data);
+ gcry_sexp_release (key);
+
+ if (rc)
+ return FALSE;
+
+ mpi = mpi_from_sexp (sig, "s");
+ hex = hex_from_mpi (mpi);
+ *result = g_strdup (hex);
+ gcry_free (hex);
+ gcry_mpi_release (mpi);
+ gcry_sexp_release (sig);
+
+ return TRUE;
+}
+
+gboolean
+displaymigration_crypt_check_signature (struct rsa_key *k, char *hash, char *sigbuf)
+{
+ gcry_mpi_t mpi, mpi2;
+ gcry_sexp_t data, sig, key;
+ int rc;
+
+ do_encode_md (hash, 20, GCRY_MD_SHA1, 1024, &mpi);
+
+ gcry_sexp_build (&data, NULL, "(data (value %m))", mpi);
+
+ gcry_mpi_release (mpi);
+
+ gcry_sexp_build (&key, NULL, "(public-key (rsa (n %m) (e %m)))", k->n, k->e);
+
+ if (gcry_mpi_scan (&mpi2, GCRYMPI_FMT_HEX, sigbuf, 0, NULL))
+ {
+ gcry_sexp_release (data);
+ return FALSE;
+ }
+
+ gcry_sexp_build (&sig, NULL, "(sig-val (rsa (s %m)))", mpi2);
+
+ rc = gcry_pk_verify (sig, data, key);
+
+ gcry_sexp_release (data);
+ gcry_sexp_release (key);
+ gcry_sexp_release (sig);
+ gcry_mpi_release (mpi2);
+
+ if (rc)
+ return FALSE;
+
+ return TRUE;
+}
diff --git a/recipes/teleport/files/fix-desktop.patch b/recipes/teleport/files/fix-desktop.patch
new file mode 100644
index 0000000000..c12434f8fd
--- /dev/null
+++ b/recipes/teleport/files/fix-desktop.patch
@@ -0,0 +1,12 @@
+--- teleport-0.33/teleport.desktop 2003-07-06 23:47:14.000000000 +0200
++++ /tmp/teleport.desktop 2005-03-04 17:34:32.193817208 +0100
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Name=Teleport
+ Comment=Move applications between displays
+-Exec=monolaunch -k /usr/share/pixmaps/teleport.png teleport
++Exec=mb-applet-launcher -k /usr/share/pixmaps/teleport.png teleport
+ Type=PanelApp
+ Icon=teleport.png
+ Categories=Panel;Utility;GPE
+
diff --git a/recipes/teleport/files/remove-tododb.patch b/recipes/teleport/files/remove-tododb.patch
new file mode 100644
index 0000000000..87e4f74b00
--- /dev/null
+++ b/recipes/teleport/files/remove-tododb.patch
@@ -0,0 +1,12 @@
+--- teleport-0.33/Makefile 2004-07-20 22:01:25.000000000 +0200
++++ teleport-0.33/Makefile 2005-03-04 17:03:17.316841832 +0100
+@@ -13,7 +13,7 @@
+ endif
+ PACKAGE_CPPFLAGS += $(STANDARD_CPPFLAGS)
+ PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GPECFLAGS) `libgcrypt-config --cflags`
+-PACKAGE_LDFLAGS += $(STANDARD_LDFLAGS) $(GPELIBS) -ltododb -ldisplaymigration -lgpepimc `libgcrypt-config --libs` -lsqlite
++PACKAGE_LDFLAGS += $(STANDARD_LDFLAGS) $(GPELIBS) -ldisplaymigration `libgcrypt-config --libs` -lsqlite
+
+ MEMBERS = teleport crypt displays keygen tp-keygen
+
+
diff --git a/recipes/teleport/teleport_0.33.bb b/recipes/teleport/teleport_0.33.bb
new file mode 100644
index 0000000000..8ebb7801e6
--- /dev/null
+++ b/recipes/teleport/teleport_0.33.bb
@@ -0,0 +1,12 @@
+inherit gpe
+LICENSE = "GPL"
+
+DESCRIPTION = "Teleport app"
+DEPENDS = "gtk+ libgpewidget libdisplaymigration libgcrypt sqlite"
+SECTION = "gpe"
+PRIORITY = "optional"
+PR = "r2"
+
+SRC_URI =+ "file://crypt.c \
+ file://fix-desktop.patch;patch=1 \
+ file://remove-tododb.patch;pnum=1;patch=1"
diff --git a/recipes/teleport/teleport_0.34.bb b/recipes/teleport/teleport_0.34.bb
new file mode 100644
index 0000000000..ce982c9490
--- /dev/null
+++ b/recipes/teleport/teleport_0.34.bb
@@ -0,0 +1,5 @@
+inherit gpe
+LICENSE = "GPL"
+DESCRIPTION = "Teleport app"
+DEPENDS = "gtk+ libgpewidget libdisplaymigration libgcrypt sqlite"
+PRIORITY = "optional"