aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/texinfo/texinfo_4.13a.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-21 01:02:02 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-21 10:42:56 -0700
commitc4df0f884f071e96faae1cd6bfccaf2c4062afa0 (patch)
treecc5963345ce905cff4d6256b70fe80f71aea54c4 /recipes/texinfo/texinfo_4.13a.bb
parentd2a283ad002660e46b2f8d40a8ddfabad457d8a4 (diff)
downloadopenembedded-c4df0f884f071e96faae1cd6bfccaf2c4062afa0.tar.gz
texinfo_4.13a.bb: Add recipe for 4.13a
* Leave the old recipe in there because new recipe is GPLv3 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/texinfo/texinfo_4.13a.bb')
-rw-r--r--recipes/texinfo/texinfo_4.13a.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/texinfo/texinfo_4.13a.bb b/recipes/texinfo/texinfo_4.13a.bb
new file mode 100644
index 0000000000..04cb0ddc77
--- /dev/null
+++ b/recipes/texinfo/texinfo_4.13a.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Documentation system for on-line information and printed output"
+HOMEPAGE = "http://www.gnu.org/software/texinfo/"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+DEPENDS = "ncurses"
+
+SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
+ file://gettext.patch \
+ "
+SRC_URI[md5sum] = "71ba711519209b5fb583fed2b3d86fcb"
+SRC_URI[sha256sum] = "1303e91a1c752b69a32666a407e9fbdd6e936def4b09bc7de30f416301530d68"
+
+inherit autotools gettext
+
+S = "${WORKDIR}/texinfo-4.13/"
+
+do_compile_prepend() {
+ oe_runmake -C tools/gnulib/lib
+}
+
+do_install_append() {
+ rm -f ${D}${libdir}/charset.alias
+}