aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/matrix-gui-e_svn.bb
diff options
context:
space:
mode:
authorChase Maupin <chase.maupin@ti.com>2010-05-27 11:01:30 -0500
committerKoen Kooi <koen@openembedded.org>2010-05-28 09:21:15 +0200
commit617eb0ac559bd46ae86a6fd9a270d862ee9adf56 (patch)
tree3018c913fd5037777556357288e90712766923ee /recipes/ti/matrix-gui-e_svn.bb
parent0539d1ef424c6e9851f2c213a1b36353c0d7330f (diff)
downloadopenembedded-617eb0ac559bd46ae86a6fd9a270d862ee9adf56.tar.gz
matrix-gui-common: Move common files into one pkg
* Created the matrix-gui-common_svn.bb recipe to contain all of the common html, scripts, and image files used by both versions of the matrix GUI application. * Removed the html, script, and image files from matrix-gui and matrix-gui-e recipes. * Added dependency on matrix-gui-common to matrix-gui and matrix-gui-e recipes. * Added browser executable that looks for the example browser from the Qt demos package depending on whether the embedded or X11 version of the matrix GUI application is running. Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/matrix-gui-e_svn.bb')
-rw-r--r--recipes/ti/matrix-gui-e_svn.bb26
1 files changed, 1 insertions, 25 deletions
diff --git a/recipes/ti/matrix-gui-e_svn.bb b/recipes/ti/matrix-gui-e_svn.bb
index 38846fecd2..0efa19b5fe 100644
--- a/recipes/ti/matrix-gui-e_svn.bb
+++ b/recipes/ti/matrix-gui-e_svn.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
SRCREV = "58"
PV = "1.0"
-PR = "r7+svnr${SRCPV}"
+PR = "r9+svnr${SRCPV}"
SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
file://init \
@@ -19,35 +19,11 @@ INITSCRIPT_PARAMS = "defaults 99"
inherit qt4e update-rc.d
-MATRIX_EXTRA_BINS = " \
- memInfo \
- networkSettings \
- runOGLES2Coverflow \
- runOGLES2Shaders \
- runOGLESChameleonMan \
- runOGLESVase \
- setopp1 \
- setopp2 \
- setopp3 \
- setopp4 \
- standby \
- sysSettings \
- taskInfo \
-"
-
do_install() {
install -d ${D}/${bindir}
install -m 0755 ${S}/matrix_gui ${D}/${bindir}/matrix_guiE
- for i in ${MATRIX_EXTRA_BINS}; do
- install -m 0755 ${S}/bin/${i} ${D}/${bindir}
- done
- install -d ${D}/${datadir}/matrix/html
- install -m 0644 ${S}/*.html ${D}/${datadir}/matrix/html/
- install -d ${D}/${datadir}/matrix/images
- install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
install -d ${D}${sysconfdir}/init.d/
install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui-e
}
RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib"
-FILES_${PN} += "${datadir}/matrix/*"