summaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-codec-engine_2.24.01.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2009-11-16 10:17:24 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-04 19:46:02 +0100
commitb788499815bfc1974d4277c0a261b9a7c24aa816 (patch)
tree6c0546c0891d884f835355d851ec07147165ddd2 /recipes/ti/ti-codec-engine_2.24.01.bb
parent08dcecdc77ceb6a3673605216493905859f11982 (diff)
downloadopenembedded-b788499815bfc1974d4277c0a261b9a7c24aa816.tar.gz
recipes/ti: merge in updates
* New codec recipes from Arago team in Germantown * Updated dm6446 and dm355 from Brijesh Singh * cmem, gst-ti and dmai fixes from Brijesh Singh angstrom: introduce SOC_FAMILY and start using it TI recipes as a testing ground * SOC_FAMILY tells you which system on chip is used in the MACHINE, e.g. omap3, dm355, pxa25x, s3c24xx. This avoids having to duplicate lots of overrides in machine specific recipes. This is *NOT* intended to be used as a package arch.
Diffstat (limited to 'recipes/ti/ti-codec-engine_2.24.01.bb')
-rw-r--r--recipes/ti/ti-codec-engine_2.24.01.bb66
1 files changed, 32 insertions, 34 deletions
diff --git a/recipes/ti/ti-codec-engine_2.24.01.bb b/recipes/ti/ti-codec-engine_2.24.01.bb
index 9be02046a4..ae0197e3d2 100644
--- a/recipes/ti/ti-codec-engine_2.24.01.bb
+++ b/recipes/ti/ti-codec-engine_2.24.01.bb
@@ -3,14 +3,14 @@ DESCRIPTION = "Codec Engine 2.24.01 for TI ARM/DSP processors"
require ti-paths.inc
# compile time dependencies
-DEPENDS = "ti-xdctools-native"
+DEPENDS = "ti-framework-components ti-xdais-native ti-xdctools-native ti-cgt6x-native"
-DEPENDS_append_dm6446-evm = " ti-cgt6x-native ti-dspbios-native ti-dsplink-module"
-DEPENDS_append_armv7a = " ti-cgt6x-native ti-dspbios-native ti-dsplink-module"
+DEPENDS_append_dm6446 = " ti-dspbios-native ti-linuxutils ti-dsplink-module"
+DEPENDS_append_omap3 = " ti-dspbios-native ti-linuxutils ti-dsplink-module"
# tconf from xdctools dislikes '.' in pwd :/
PR = "r7"
-PV = "2241"
+PV = "2_24_01"
SRC_URI = "http://install.source.dir.local/codec_engine_2_24_01.tar.gz "
@@ -18,19 +18,18 @@ SRC_URI = "http://install.source.dir.local/codec_engine_2_24_01.tar.gz "
S = "${WORKDIR}/codec_engine_2_24_01"
# Define Device variable
-DEVICES_dm6446-evm ?= "DM6446"
-
-# define gppos variable
-GPPOS_dm6446-evm ?= "LINUX_GCC"
+DEVICES_dm6446 ?= "DM6446"
+DEVICES_omap3 ?= "OMAP3530"
+DEVICES_dm355 ?= "DM355"
#define PROGRAM variables
-PROGRAMS = "APP_CLIENT DSP_SERVER"
+PROGRAMS ?= "APP_CLIENT DSP_SERVER"
+PROGRAMS_dm355 = "APP_LOCAL"
LINK_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-dsplink-module/packages"
-DSPBIOS_DIR="${STAGING_DIR_NATIVE}/ti-dspbios-native"
-CGT6x_DIR="${STAGING_DIR_NATIVE}/ti-cgt6x-native"
-XDCTOOLS_DIR="${STAGING_DIR_NATIVE}/ti-xdctools-native"
-CE_INSTALL_DIR="${S}"
+CGT6x_DIR = "${STAGING_DIR_NATIVE}/ti-cgt6x-native"
+XDCTOOLS_DIR = "${STAGING_DIR_NATIVE}/ti-xdctools-native"
+CE_INSTALL_DIR = "${S}"
do_compile () {
@@ -38,35 +37,34 @@ do_compile () {
-e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
${S}/examples/xdcpaths.mak
- for i in codecs extensions servers apps ; do
- cd ${S}/examples/ti/sdo/ce/examples/$i
- make DEVICES="${DEVICES}" \
- GPPOS="${GPPOS}" \
- PROGRAMS="${PROGRAMS}" \
- CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
- XDC_INSTALL_DIR="${XDCTOOLS_DIR}" \
- BIOS_INSTALL_DIR="${DSPBIOS_DIR}"\
- DSPLINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
- XDAIS_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- FC_INSTALL_DIR="${FC_INSTALL_DIR}" \
- CMEM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- LPM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- EDMA3_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- FC_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- CGTOOLS_V5T="${CROSS_DIR}"\
- CGTOOLS_C64P="${CGT6x_DIR}" \
- clean all
- done
+ for i in codecs extensions servers apps ; do
+ cd ${S}/examples/ti/sdo/ce/examples/$i
+ make DEVICES="${DEVICES}" \
+ GPPOS="${GPPOS}" \
+ PROGRAMS="${PROGRAMS}" \
+ CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
+ XDC_INSTALL_DIR="${XDCTOOLS_DIR}" \
+ BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}"\
+ DSPLINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
+ XDAIS_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
+ FC_INSTALL_DIR="${FC_INSTALL_DIR}" \
+ CMEM_INSTALL_DIR="${CMEM_INSTALL_DIR}" \
+ LPM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
+ EDMA3_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
+ CGTOOLS_V5T="${CROSS_DIR}"\
+ CGTOOLS_C64P="${CGT6x_DIR}" \
+ clean all
+ done
}
do_install() {
install -d ${D}/${installdir}/codec-engine-apps
- cp ${S}/examples/apps/system_files/${DEVICES}/loadmodules.sh ${D}/${installdir}/codec-engine-apps
+ cp ${S}/examples/apps/system_files/${DEVICES}/loadmodules.sh ${D}/${installdir}/codec-engine-apps
sed -i 's/insmod/modprobe/g' ${D}/${installdir}/codec-engine-apps/loadmodules.sh
cd ${S}/examples/ti/sdo/ce/examples
- for i in $(find . -name "*.xv5T"); do
+ for i in $(find . -name "*.xv5T"); do
install -d ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`
install ${i} ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`