aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-codecs-dm365_3.10.00.05.bb
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2010-05-08 11:42:48 -0500
committerKoen Kooi <koen@openembedded.org>2010-06-12 11:03:50 +0200
commit1e61802cb044de88abf54dea6e8604e27ab41b62 (patch)
tree4e0756b707f5e15ea78a0b7c454e2b8ada6bbf23 /recipes/ti/ti-codecs-dm365_3.10.00.05.bb
parent73bb08cec9ebc51d7944d42c0a954bfd89200274 (diff)
downloadopenembedded-1e61802cb044de88abf54dea6e8604e27ab41b62.tar.gz
ti-codecs-dm365_3.10.00.05: add newer version of codec server
Signed-off-by: Brijesh Singh <bksingh@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/ti-codecs-dm365_3.10.00.05.bb')
-rw-r--r--recipes/ti/ti-codecs-dm365_3.10.00.05.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/ti/ti-codecs-dm365_3.10.00.05.bb b/recipes/ti/ti-codecs-dm365_3.10.00.05.bb
new file mode 100644
index 0000000000..0542d66360
--- /dev/null
+++ b/recipes/ti/ti-codecs-dm365_3.10.00.05.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "DM365 Codecs"
+SECTION = "multimedia"
+LICENSE = "TI"
+
+PV = "03_10_00_05"
+
+SRC_URI = "http://gt_tspa_dev.gt.design.ti.com/dev/DVSDK/310_DVSDK/3_10_00/dm365_codecs_${PV}.tar.gz;name=dm365codecs \
+ file://mapdmaq"
+
+SRC_URI[dm365codecs.md5sum] = "c336e76101340b7a4f19214401824efe"
+SRC_URI[dm365codecs.sha256sum] = "3ad43dcaf1b965c99a286f30cea928cf887308f7433ec0e6fd814954d91d0512"
+
+S = "${WORKDIR}/dm365_codecs_${PV}"
+
+PROVIDES += "ti-codecs-dm365-server"
+
+require ti-paths.inc
+require ti-staging.inc
+
+do_compile() {
+ echo "Do nothing"
+}
+
+do_install () {
+ install -d ${D}/${installdir}/ti-codecs-server
+ cd ${S}
+
+ install -m 0755 ${WORKDIR}/mapdmaq ${D}/${installdir}/ti-codecs-server
+
+ install -d ${D}${CODEC_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${CODEC_INSTALL_DIR_RECIPE}
+}
+
+PACKAGES += "ti-codecs-dm365-server"
+FILES_ti-codecs-dm365-server = "${installdir}/ti-codecs-server/*"
+
+INSANE_SKIP_ti-codecs-dm365-server = True