aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-05 10:12:13 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-05 10:12:59 +0100
commit01ffe4edd15741590cc825aad2281d83ca42fc16 (patch)
tree67046969850c9aa61fdb8e2ca1ecb67682d73c62 /recipes/ti
parent3a8c8d04f734b72673d397c81b23398b982608a7 (diff)
downloadopenembedded-01ffe4edd15741590cc825aad2281d83ca42fc16.tar.gz
ti-c6accel 1.01.00.03: add patch to fix link problem
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-c6accel.inc2
-rw-r--r--recipes/ti/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch26
-rw-r--r--recipes/ti/ti-c6accel_1.01.00.03.bb1
3 files changed, 28 insertions, 1 deletions
diff --git a/recipes/ti/ti-c6accel.inc b/recipes/ti/ti-c6accel.inc
index da513cf92b..777ece246e 100644
--- a/recipes/ti/ti-c6accel.inc
+++ b/recipes/ti/ti-c6accel.inc
@@ -18,7 +18,7 @@ PROVIDES += "ti-c6accel-apps"
# This recipe links statically against kernel dependant stuff, use kernel PR as base and append a local version
PR = "${MACHINE_KERNEL_PR}"
-PR_append = "a"
+PR_append = "b"
S = "${WORKDIR}/c6accel_${PV}"
diff --git a/recipes/ti/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch b/recipes/ti/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch
new file mode 100644
index 0000000000..901e11df85
--- /dev/null
+++ b/recipes/ti/ti-c6accel/0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch
@@ -0,0 +1,26 @@
+From 58c50064afdc2fd7093613e0ae3a9192ea189460 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 5 Jan 2011 10:10:33 +0100
+Subject: [PATCH] soc/app: fix makefile to pass -Wl,-T, before the linkerscript
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ soc/app/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/soc/app/Makefile b/soc/app/Makefile
+index 0bb7bdc..342e43a 100755
+--- a/soc/app/Makefile
++++ b/soc/app/Makefile
+@@ -33,7 +33,7 @@ XDC_CFG = $(TARGET)_config
+ XDC_CFLAGS = $(XDC_CFG)/compiler.opt
+
+ # Output linker file
+-XDC_LFILE = $(XDC_CFG)/linker.cmd
++XDC_LFILE = -Wl,-T,$(XDC_CFG)/linker.cmd
+
+ # Input configuration file
+ XDC_CFGFILE = $(PLATFORM)/$(TARGET).cfg
+--
+1.6.6.1
+
diff --git a/recipes/ti/ti-c6accel_1.01.00.03.bb b/recipes/ti/ti-c6accel_1.01.00.03.bb
index bf5f1cf35b..15e2d058a3 100644
--- a/recipes/ti/ti-c6accel_1.01.00.03.bb
+++ b/recipes/ti/ti-c6accel_1.01.00.03.bb
@@ -5,6 +5,7 @@ SRC_URI[c6accelbin.sha256sum] = "453399a84bf117bd7a91393242c7c005e2829692db5ede1
SRC_URI_append = "file://fix-loadmodule.patch \
file://0001-soc-honour-buildsystem-CFLAGS-and-LDFLAGS-when-set.patch \
+ file://0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch \
"
PV = "1_01_00_03"