aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-11-29 12:11:13 +0100
committerKoen Kooi <koen@openembedded.org>2010-11-29 12:11:13 +0100
commit152cf43ce7980fafd7a227eab580caeaa5c4cadc (patch)
tree45cf933a51b5ba583920ad01fca8c6fc74c06840 /recipes/ti
parent147ee4f35b90672e2ab7cabd2c307326553ec594 (diff)
downloadopenembedded-152cf43ce7980fafd7a227eab580caeaa5c4cadc.tar.gz
ti framework components: add version 3.20.00.22
FC 3.x is intended for SYS/BIOS 6 users. DSP/BIOS 5 users (including most DVSDK users) should continue to use FC 2.x releases! Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-framework-components3.inc17
-rw-r--r--recipes/ti/ti-framework-components3_3.20.00.22.bb8
-rw-r--r--recipes/ti/ti-paths.inc2
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes/ti/ti-framework-components3.inc b/recipes/ti/ti-framework-components3.inc
new file mode 100644
index 0000000000..67e989ac5a
--- /dev/null
+++ b/recipes/ti/ti-framework-components3.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "TI Framework Components"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc"
+SECTION = "devel"
+LICENSE = "BSD"
+
+require ti-paths.inc
+require ti-staging.inc
+
+S = "${WORKDIR}/framework_components_${PV}"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball"
+
+do_install() {
+ install -d ${D}${FC3_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${FC3_INSTALL_DIR_RECIPE}
+}
+
diff --git a/recipes/ti/ti-framework-components3_3.20.00.22.bb b/recipes/ti/ti-framework-components3_3.20.00.22.bb
new file mode 100644
index 0000000000..404f67d445
--- /dev/null
+++ b/recipes/ti/ti-framework-components3_3.20.00.22.bb
@@ -0,0 +1,8 @@
+require ti-framework-components3.inc
+
+PV = "3_20_00_22"
+
+SRC_URI[fctarball.md5sum] = "13165d5f68f8bc9ee35de447c748b8ae"
+SRC_URI[fctarball.sha256sum] = "8a852707a13c5b2bba4d0dc226d234638da0560ec74c1e68a70c81dac42e143f"
+
+
diff --git a/recipes/ti/ti-paths.inc b/recipes/ti/ti-paths.inc
index 1edb10c12d..755fcf1ac8 100644
--- a/recipes/ti/ti-paths.inc
+++ b/recipes/ti/ti-paths.inc
@@ -8,6 +8,7 @@ export BIOS_INSTALL_DIR_RECIPE = "${installdir}/ti-dspbios-tree"
export SYSBIOS_INSTALL_DIR_RECIPE = "${installdir}/ti-sysbios-tree"
export BIOSUTILS_INSTALL_DIR_RECIPE = "${installdir}/ti-biosutils-tree"
export FC_INSTALL_DIR_RECIPE = "${installdir}/ti-framework-components-tree"
+export FC3_INSTALL_DIR_RECIPE = "${installdir}/ti-framework-components3-tree"
export CE_INSTALL_DIR_RECIPE = "${installdir}/ti-codec-engine-tree"
export EDMA3_LLD_INSTALL_DIR_RECIPE = "${installdir}/ti-edma3lld-tree"
export EDMA3_LLD_SYSBIOS_INSTALL_DIR_RECIPE = "${installdir}/ti-edma3lld-sysbios-tree"
@@ -33,6 +34,7 @@ export BIOS_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${BIOS_IN
export SYSBIOS_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${SYSBIOS_INSTALL_DIR_RECIPE}"
export BIOSUTILS_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${BIOSUTILS_INSTALL_DIR_RECIPE}"
export FC_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${FC_INSTALL_DIR_RECIPE}"
+export FC3_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${FC3_INSTALL_DIR_RECIPE}"
export CE_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${CE_INSTALL_DIR_RECIPE}"
export EDMA3_LLD_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${EDMA3_LLD_INSTALL_DIR_RECIPE}"
export EDMA3_LLD_SYSBIOS_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${EDMA3_LLD_SYSBIOS_INSTALL_DIR_RECIPE}"