aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoman Khimov <khimov@altell.ru>2010-04-18 22:41:40 +0000
committerRoman I Khimov <khimov@altell.ru>2010-04-25 17:13:15 +0400
commit23e874a12711ee156bba5f1bbcd9fa8dd3f2ef83 (patch)
tree54e0523244d3710850111f6c95b1a1c62923ad14 /recipes/ti
parentdd7c2be839a8db7d4afaab6e700b4f81c24fb489 (diff)
downloadopenembedded-23e874a12711ee156bba5f1bbcd9fa8dd3f2ef83.tar.gz
change INHIBIT_PACKAGE_STRIP to PACKAGE_STRIP with more options
Originally approached with "package.bbclass: introduce KEEP_GNU_DEBUGLINK": http://patchwork.openembedded.org/patch/886/ Redone with a change from INHIBIT_PACKAGE_STRIP to PACKAGE_STRIP which allows more options. By default it does exactly the same thing as is done today, strips the binary, but keeps the gnu.debuglink section. When set to "no", stripping is not done at all, when set to "full" the gnu.debuglink section is not re-added to the binary. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/README2
-rw-r--r--recipes/ti/ti-codecs-dm6467_1.0.0.bb2
-rw-r--r--recipes/ti/ti-dm355mm-module_1.13.bb2
-rw-r--r--recipes/ti/ti-dm365mm-module.inc2
-rw-r--r--recipes/ti/ti-dvsdk-demos.inc2
-rw-r--r--recipes/ti/ti-linuxutils.inc2
-rw-r--r--recipes/ti/ti-staging.inc2
7 files changed, 7 insertions, 7 deletions
diff --git a/recipes/ti/README b/recipes/ti/README
index eed00f0253..2fbb9f1bbc 100644
--- a/recipes/ti/README
+++ b/recipes/ti/README
@@ -30,7 +30,7 @@ The complete unpacked trees are staged to staging/machine/usr/share/ti/${PN}(-tr
PACKAGE_ARCH = "${MACHINE_ARCH}"
BASEPKG_HOST_SYS = "${MULTIMACH_HOST_SYS}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
The 'BASEPKG_HOST_SYS' bit is what makes it work, but cause trouble is you want to read from it, so ti-paths.inc does:
diff --git a/recipes/ti/ti-codecs-dm6467_1.0.0.bb b/recipes/ti/ti-codecs-dm6467_1.0.0.bb
index 9454b94ee4..709b21f0a3 100644
--- a/recipes/ti/ti-codecs-dm6467_1.0.0.bb
+++ b/recipes/ti/ti-codecs-dm6467_1.0.0.bb
@@ -38,4 +38,4 @@ do_install () {
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
diff --git a/recipes/ti/ti-dm355mm-module_1.13.bb b/recipes/ti/ti-dm355mm-module_1.13.bb
index f7bd83123a..0308ab164a 100644
--- a/recipes/ti/ti-dm355mm-module_1.13.bb
+++ b/recipes/ti/ti-dm355mm-module_1.13.bb
@@ -39,7 +39,7 @@ do_install () {
install -m 0755 ${S}/dm355mm/module/dm350mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
}
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
SRC_URI[md5sum] = "f6221188bea76b7aaf0c45e9bcf26329"
SRC_URI[sha256sum] = "f1a6dea51be9798903a0543fb50f463b0594b1f11b897bc50e40825fb7527c61"
diff --git a/recipes/ti/ti-dm365mm-module.inc b/recipes/ti/ti-dm365mm-module.inc
index 6b0497bc9e..caf0441a99 100644
--- a/recipes/ti/ti-dm365mm-module.inc
+++ b/recipes/ti/ti-dm365mm-module.inc
@@ -25,5 +25,5 @@ do_install () {
install -m 0755 ${S}/module/dm365mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
}
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
INSANE_SKIP_${PN} = True
diff --git a/recipes/ti/ti-dvsdk-demos.inc b/recipes/ti/ti-dvsdk-demos.inc
index 99e9875dd1..af1ecd8b97 100644
--- a/recipes/ti/ti-dvsdk-demos.inc
+++ b/recipes/ti/ti-dvsdk-demos.inc
@@ -64,5 +64,5 @@ FILES_${PN} = "${installdir}/dvsdk-demos/*"
BASE_SRC_URI ?= "http://install.source.dir.local"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
INSANE_SKIP_${PN} = "True"
diff --git a/recipes/ti/ti-linuxutils.inc b/recipes/ti/ti-linuxutils.inc
index 3482d707ab..209299deea 100644
--- a/recipes/ti/ti-linuxutils.inc
+++ b/recipes/ti/ti-linuxutils.inc
@@ -83,4 +83,4 @@ FILES_ti-irq-module = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/irq*.ko
FILES_ti-linuxutils-app = "${installdir}/ti-linuxutils-app/*/*"
INSANE_SKIP_ti-linuxutils-app = "True"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
diff --git a/recipes/ti/ti-staging.inc b/recipes/ti/ti-staging.inc
index faa24616cd..593f094969 100644
--- a/recipes/ti/ti-staging.inc
+++ b/recipes/ti/ti-staging.inc
@@ -6,7 +6,7 @@ BASEPKG_HOST_SYS = "${MULTIMACH_HOST_SYS}"
# Search archdir for shlibs instead of machine dir due to above BASEPKG_HOST_SYS
SHLIBSDIR = "${STAGING_DIR}/${BASE_PACKAGE_ARCH}${HOST_VENDOR}-${HOST_OS}/shlibs"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
ALLOW_EMPTY_${PN} = "1"
ALLOW_EMPTY_${PN}-dev = "1"