aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorJeff Lance <j-lance1@ti.com>2010-09-23 09:41:35 +0000
committerDenys Dmytriyenko <denis@denix.org>2010-09-27 11:56:35 -0400
commit2645779a2605594c330ebce941b7006e8746e596 (patch)
treebd524abb9bb1873314a5431e9802368f99ae5e73 /recipes/ti
parent8a7be2280078638b0bceeb9d8f790227683263d1 (diff)
downloadopenembedded-2645779a2605594c330ebce941b7006e8746e596.tar.gz
matrix-gui-common: update to latest sources
* Updated to use repository revision 131 * This includes platform support * Removed the browser binary * Copy files based on PLATFORM * Bumped SRCREV to 136 in version 2 of this patch Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Jeff Lance <j-lance1@ti.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/matrix-gui-common/browser20
-rw-r--r--recipes/ti/matrix-gui-common_svn.bb42
2 files changed, 16 insertions, 46 deletions
diff --git a/recipes/ti/matrix-gui-common/browser b/recipes/ti/matrix-gui-common/browser
deleted file mode 100644
index b5202d5a14..0000000000
--- a/recipes/ti/matrix-gui-common/browser
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-BROWSERDIR=""
-BROWSERAPP="browser"
-
-#Check if DISPLAY is set. If so we assume we are running in X11
-#and will call the X11 version of the browser if it exists.
-if [ "$DISPLAY" == "" ]
-then
- BROWSERDIR="/usr/bin/qtopia/demos/browser"
-else
- BROWSERDIR="/usr/bin/qt4/demos/browser"
-fi
-
-if [ -e "$BROWSERDIR/$BROWSERAPP" ]
-then
- cd $BROWSERDIR
- ./$BROWSERAPP
-fi
-
diff --git a/recipes/ti/matrix-gui-common_svn.bb b/recipes/ti/matrix-gui-common_svn.bb
index 43d6b0c8bf..89126a2e29 100644
--- a/recipes/ti/matrix-gui-common_svn.bb
+++ b/recipes/ti/matrix-gui-common_svn.bb
@@ -4,44 +4,34 @@ LICENSE = "BSD"
SECTION = "multimedia"
PRIORITY = "optional"
-SRCREV = "58"
-PV = "1.0"
-PR = "r1+svnr${SRCPV}"
+SRCREV = "136"
+PV = "1.1"
+PR = "r3+svnr${SRCPV}"
+
+PLATFORM_dm365 = "dm365"
+PLATFORM_da850-omapl138-evm = "omapl138"
+PLATFORM_omap3evm = "omap3530"
+PLATFORM_dm37x-evm = "dm3730"
+PLATFORM_am37x-evm = "am3715"
+PLATFORM_beagleboard = "am3715"
+PLATFORM ?= "<UNDEFINED>"
#Checkout the project repository to get access to the scripts and data
#files.
-SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
- file://browser \
-"
+SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
S = "${WORKDIR}/trunk"
-MATRIX_EXTRA_BINS = " \
- memInfo \
- networkSettings \
- runOGLES2Coverflow \
- runOGLES2Shaders \
- runOGLESChameleonMan \
- runOGLESVase \
- setopp1 \
- setopp2 \
- setopp3 \
- setopp4 \
- standby \
- sysSettings \
- taskInfo \
-"
+PACKAGE_ARCH = ${MACHINE_ARCH}
do_install() {
install -d ${D}/${bindir}
- for i in ${MATRIX_EXTRA_BINS}; do
- install -m 0755 ${S}/bin/${i} ${D}/${bindir}
- done
- install -m 0755 ${WORKDIR}/browser ${D}/${bindir}
+ install -m 0755 ${S}/${PLATFORM}/bin/* ${D}/${bindir}/
install -d ${D}/${datadir}/matrix/html
- install -m 0644 ${S}/*.html ${D}/${datadir}/matrix/html/
+ install -m 0644 ${S}/${PLATFORM}/html/* ${D}/${datadir}/matrix/html
install -d ${D}/${datadir}/matrix/images
install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
+
}
FILES_${PN} += "${datadir}/matrix/*"