aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorchase maupin <chasemaupin03@gmail.com>2011-01-05 03:36:17 +0000
committerKoen Kooi <koen@openembedded.org>2011-01-05 09:23:51 +0100
commit2d922abff747c6e3eb3566e1d2afa5efb9cdd515 (patch)
tree70b8d34086a969fbbcbd122007388bb221ff294a /recipes/ti
parent4fe0ecff0e386af84032f9d485551904a8e6a11c (diff)
downloadopenembedded-2d922abff747c6e3eb3566e1d2afa5efb9cdd515.tar.gz
matrix-tui: adding multi platform support
* adding am180x, am181x, da850-omapl138, am3517 and am3715 support * Updating SRC rev to pull in matrix-tui project with platform support * removing INSANE_SKIP, it originally handled pre-built binaries which have since been removed * Creating version 1.1 of the recipe * matrix-tui.inc with platform support is backwards compatible with previous versions Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Jeff Lance <j-lance@ti.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/matrix-tui.inc12
-rw-r--r--recipes/ti/matrix-tui_1.1.bb4
2 files changed, 14 insertions, 2 deletions
diff --git a/recipes/ti/matrix-tui.inc b/recipes/ti/matrix-tui.inc
index 6983406d07..1ad8aa894b 100644
--- a/recipes/ti/matrix-tui.inc
+++ b/recipes/ti/matrix-tui.inc
@@ -5,9 +5,16 @@ SECTION = "multimedia"
PRIORITY = "optional"
DEPENDS = "libxml2 zlib ncurses"
-INC_PR = "r5"
+INC_PR = "r7"
-INSANE_SKIP_${PN} = "True"
+COMPATIBLE_MACHINE = "(omapl138|omap3)"
+
+PLATFORM_am37x-evm = "am3715"
+PLATFORM_beagleboard = "am3715"
+PLATFORM_am3517-evm = "am3517"
+PLATFORM_am180x-evm = "am180x"
+PLATFORM_am181x-evm = "am181x"
+PLATFORM_da850-omapl138-evm = "am180x"
SRC_URI = "svn://gforge.ti.com/svn/matrix_tui/;module=trunk;proto=https;user=anonymous;pswd='' \
file://init \
@@ -36,6 +43,7 @@ do_compile() {
}
do_install() {
+ export PLATFORM=${PLATFORM}
make DESTDIR=${D} install
install -d ${D}${sysconfdir}/init.d/
install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-tui
diff --git a/recipes/ti/matrix-tui_1.1.bb b/recipes/ti/matrix-tui_1.1.bb
new file mode 100644
index 0000000000..8f2ccbe15c
--- /dev/null
+++ b/recipes/ti/matrix-tui_1.1.bb
@@ -0,0 +1,4 @@
+require matrix-tui.inc
+
+SRCREV = "34"
+PR = "${INC_PR}.2"