aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-08 10:25:38 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-08 10:25:38 +0100
commit2f1b81eb90e1259c55fe0b7e904c1e3a5d7614a0 (patch)
treeee62e43b82b8e67dce59b13dccbcf3914c621e13 /recipes/ti
parent3ff1afa5870f01090e9d49e92478170ae966cc8e (diff)
downloadopenembedded-2f1b81eb90e1259c55fe0b7e904c1e3a5d7614a0.tar.gz
ti-pru-sw-edma-driver: remove hardcodes from makefile
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb b/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
index 5747f3db2e..1d3676f2eb 100644
--- a/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
+++ b/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
@@ -14,6 +14,11 @@ PACKAGE_STRIP = "no"
inherit module
PR = "${MACHINE_KERNEL_PR}+svnr${SRCPV}"
+# Fix silly hardcodes, module.bbclass puts in the *correct* values
+do_compile_prepend() {
+ sed -i 's:ARCH=arm CROSS_COMPILE=$(CSTOOL_PREFIX)::g' Makefile
+}
+
do_install () {
install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru
install -m 0755 ${S}/edmautils.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/