aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorMelissa Watkins <m-watkins@ti.com>2010-12-02 05:16:06 -0600
committerKoen Kooi <koen@openembedded.org>2010-12-04 12:53:59 +0100
commit66dd7b35757353ef0afc91ce7e2c7f4d838c9832 (patch)
tree6cf112a1541e1c5f03fa0d434af3aa03892d6526 /recipes/ti
parentcfd4a39d14e0d51ec9501febb447cb8bfaa82efc (diff)
downloadopenembedded-66dd7b35757353ef0afc91ce7e2c7f4d838c9832.tar.gz
ti-pru-sw-edma-library: first addition of PRU sw edma library
* Add PRU sw edma library recipe for the omapl138 and am181x-evm machines This recipe builds and stages the edma user space libraries for use by the PRU sw. Because the edma APIs available by the kernel can only be called by kernel drivers, similar user space APIs (provided through this recipe) were needed. These libraries depend on a kernel module built by the ti-pru-sw-edma-driver recipe. Signed-off-by: Melissa Watkins <m-watkins@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-pru-sw-edma-library_1.00.00.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb b/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb
new file mode 100644
index 0000000000..76d0bdcb6e
--- /dev/null
+++ b/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "eDMA library for use by PRU sw example applications"
+HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
+LICENSE = "BSD"
+PR = "r0+svnr${SRCPV}"
+
+RDEPENDS_${PN} += "ti-pru-sw-edma-driver"
+DEPENDS += "virtual/kernel"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "omapl138|am180x-evm|am181x-evm"
+
+SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+SRCREV = "18"
+S = "${WORKDIR}/trunk/peripheral_lib/edma_driver/interface"
+
+do_compile () {
+ oe_runmake KERNEL_DIR="${STAGING_KERNEL_DIR}"
+}
+
+do_install () {
+ install -d ${D}/${libdir}
+ install -m 0755 ${S}/../lib/libedmautils.a ${D}/${libdir}/
+}
+