aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorMelissa Watkins <m-watkins@ti.com>2010-12-02 05:11:36 -0600
committerKoen Kooi <koen@openembedded.org>2010-12-04 12:54:00 +0100
commit672f472b0842b3607835b3e9f7dbf0e3195dae57 (patch)
tree72ad7d601baa67b97365e43e69c196580c5da597 /recipes/ti
parentf3a58927748f0aa2e25cc167fa91c605266f742c (diff)
downloadopenembedded-672f472b0842b3607835b3e9f7dbf0e3195dae57.tar.gz
ti-pru-sw-example: first addition of PRU sw examples recipe
* Add PRU sw examples recipe for the omapl138 machines The ti-pru-sw-example recipe builds example codes that demonstrate use of the AM180x-evm PRU, compiles the PRU binaries, and saves example executables and binaries to the filesystem. The examples included and manual building instructions are outlined at: http://processors.wiki.ti.com/index.php/PRU_Linux-based_Example_Code Signed-off-by: Melissa Watkins <m-watkins@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rwxr-xr-xrecipes/ti/ti-pru-sw-examples_1.00.00.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/ti/ti-pru-sw-examples_1.00.00.bb b/recipes/ti/ti-pru-sw-examples_1.00.00.bb
new file mode 100755
index 0000000000..a9239f8724
--- /dev/null
+++ b/recipes/ti/ti-pru-sw-examples_1.00.00.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "PRU sw example applications"
+HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
+LICENSE = "BSD"
+DEPENDS = "ti-pru-sw-app-loader ti-pru-sw-edma-library"
+PR = "r0+svnr${SRCPV}"
+
+COMPATIBLE_MACHINE = "omapl138|am180x-evm"
+
+SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+SRCREV = "18"
+S = "${WORKDIR}/trunk"
+
+do_compile () {
+ make -C ${S}/example_apps LIBDIR_APP_LOADER="${D}${libdir}" \
+ CC=${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}gcc \
+ LIBDIR_EDMA_LOADER="${D}${libdir}}" \
+ INCDIR_APP_LOADER="${D}${includedir}" \
+ INCDIR_EDMA_DRIVER="${D}${includedir}" \
+ BINDIR_APPLICATIONS="${S}/example_apps/bin" \
+ BINDIR_FW="${S}/example_apps/bin" \
+ UTILS_DIR="${S}/utils"
+}
+
+do_install () {
+ install -d ${D}/usr/share/ti/ti-pru-eg/
+ install -m 0755 ${S}/example_apps/bin/* ${D}/usr/share/ti/ti-pru-eg/
+}
+
+FILES_${PN} += "${datadir}/ti/ti-pru-eg/*"
+FILES_${PN}-dbg += "${datadir}/ti/ti-pru-eg/.debug/*"