aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-06-28 16:47:41 +0100
committerKoen Kooi <koen@openembedded.org>2010-06-29 16:42:38 +0200
commit78c66a51b7a88e4106603a857199efeefdb05864 (patch)
tree3ff2a396349d21a451896b213320afe93d1a5dbc /recipes/ti
parenta83d6dea3e209eac4c04c3ae82118e39beb316e3 (diff)
downloadopenembedded-78c66a51b7a88e4106603a857199efeefdb05864.tar.gz
ti-biospsp: Add Preliminary Support for (DSP)/BIOS PSP (Platform Support Package) for OMAPL13x (v1.30.01)
* Initial support from Arnie/Brijesh * v 1.30.01 * BIOS PSP is Device Drivers for DSP side BIOS Kernel * URLs are currently internal - externel links to be added * Sources can be fetched from download page and unpackad with windows installer in interim * Components are installed only, not rebuilt currently Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-biospsp.inc32
-rw-r--r--recipes/ti/ti-biospsp_01.30.01.bb11
-rw-r--r--recipes/ti/ti-paths.inc2
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes/ti/ti-biospsp.inc b/recipes/ti/ti-biospsp.inc
new file mode 100644
index 0000000000..6aac89de62
--- /dev/null
+++ b/recipes/ti/ti-biospsp.inc
@@ -0,0 +1,32 @@
+DESCRIPTION = "TI (DSP/) BIOS Platform Support Package (PSP)"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/psp/BIOSPSP/01_30_01/index_FDS.html"
+SECTION = "devel"
+LICENSE = "TI BSD"
+
+require ti-paths.inc
+require ti-staging.inc
+
+COMPATIBLE_MACHINE = "(da830-omapl137-evm|da850-omapl138-evm)"
+
+PR = "r2"
+
+S = "${WORKDIR}/pspdrivers_${PV}"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/psp/BIOSPSP/${PV}/content/BIOSPSP_${PV}_Setup.exe;name=biospsptarball"
+
+# No real depends right now since we're not building anything - placeholder for now
+DEPENDS = "ti-cgt6x ti-dspbios ti-edma3lld"
+
+do_configure() {
+ echo "Do Nothing for now"
+}
+
+do_compile() {
+ echo "Do Nothing for now"
+}
+
+do_install() {
+ install -d ${D}${BIOSPSP_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${BIOSPSP_INSTALL_DIR_RECIPE}
+}
+
diff --git a/recipes/ti/ti-biospsp_01.30.01.bb b/recipes/ti/ti-biospsp_01.30.01.bb
new file mode 100644
index 0000000000..118e90d93b
--- /dev/null
+++ b/recipes/ti/ti-biospsp_01.30.01.bb
@@ -0,0 +1,11 @@
+require ti-biospsp.inc
+
+PV = "01_30_01"
+
+SRC_URI[biospsptarball.md5sum] = "92096326d0b6d82bac758b622b5f2b50"
+SRC_URI[biospsptarball.sha256sum] = "87acc688c06152569b8faa1480ff5f0c040e2fbdd6c2a4a0b30b8d8b0aa72314"
+
+# Internal Release Only - SRC_URI is not public yet - override link
+HTTP_PROXY_IGNORE="ftp.india.ti.com"
+SRC_URI = "ftp://ftp.india.ti.com/PSP/Releases/ODC/Freon_BIOS_PSP/REL.BIOSPSP.01.30.01.GA/BIOSPSP_${PV}.tar.gz;name=biospsptarball"
+
diff --git a/recipes/ti/ti-paths.inc b/recipes/ti/ti-paths.inc
index 15cd51966f..86852eb535 100644
--- a/recipes/ti/ti-paths.inc
+++ b/recipes/ti/ti-paths.inc
@@ -18,6 +18,7 @@ export DMAI_INSTALL_DIR_RECIPE = "${installdir}/ti-dmai-tree"
export CODEC_INSTALL_DIR_RECIPE = "${installdir}/ti-codecs-tree"
export DSPLIB_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-tree"
export DVSDK_DEMOS_INSTALL_DIR_RECIPE = "${installdir}/ti-dvsdk-demos-tree"
+export BIOSPSP_INSTALL_DIR_RECIPE = "${installdir}/ti-biospsp-tree"
# This is where the tools will end up in staging provided PACKAGE_ARCH = ${MACHINE_ARCH} is set
export CODEGEN_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${CODEGEN_INSTALL_DIR_RECIPE}"
@@ -36,6 +37,7 @@ export LPM_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${LPM_INS
export DMAI_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${DMAI_INSTALL_DIR_RECIPE}"
export CODEC_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${CODEC_INSTALL_DIR_RECIPE}"
export DSPLIB_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${DSPLIB_INSTALL_DIR_RECIPE}"
+export BIOSPSP_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${BIOSPSP_INSTALL_DIR_RECIPE}"
DSPSUFFIX_omapl137 = "x674"
DSPSUFFIX_omapl138 = "x674"