aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-04-22 01:41:35 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-22 13:21:55 +0200
commit791c15ebf502329edb3a9a535d7ef61da0d3ffa2 (patch)
tree1b76c940565fa22ec836153d6cc6d486fbe79874 /recipes/ti
parente8c0ffc828960eeae4a64245f08e20df9c358706 (diff)
downloadopenembedded-791c15ebf502329edb3a9a535d7ef61da0d3ffa2.tar.gz
ti-dsplink: Move dsplink_1.64 fix-ups into version specific recipe
* Fix-ups for kernel headers and CROSS_COMPILE are specific to 1.64 Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-dsplink.inc7
-rw-r--r--recipes/ti/ti-dsplink_1.64.bb14
2 files changed, 13 insertions, 8 deletions
diff --git a/recipes/ti/ti-dsplink.inc b/recipes/ti/ti-dsplink.inc
index c0171f193a..b13b46931b 100644
--- a/recipes/ti/ti-dsplink.inc
+++ b/recipes/ti/ti-dsplink.inc
@@ -64,13 +64,6 @@ export DSPLINK
do_configure() {
- # asm/page.h is gone with linux-libc-headers 2.6.31.
- # We can safely sed it out since it has been empty for the past 2 years
- sed -i /page.h/d ${S}/dsplink/gpp/src/api/Linux/drv_api.c || true
-
- # Makefile passes hardcoded CROSS_COMPILE - rename so this doesnt get passed to kbuild
- sed -i -e s:CROSS_COMPILE:BOGUS_CROSS_COMPILE:g ${S}/dsplink/gpp/src/Rules.mk
-
# Run perl script to create appropriate makefiles (v1.60 and up)
(
cd ${DSPLINK}
diff --git a/recipes/ti/ti-dsplink_1.64.bb b/recipes/ti/ti-dsplink_1.64.bb
index 3f1332bd9b..bf45ea8a78 100644
--- a/recipes/ti/ti-dsplink_1.64.bb
+++ b/recipes/ti/ti-dsplink_1.64.bb
@@ -10,6 +10,19 @@ SRC_URI_append = "file://dsplink_1_64_kernel_2_6_33_autoconf.patch;patch=1 \
file://dsplink_1_64_add_dm6446_build_support.patch;patch=1 \
file://dsplink_1_64_add_omapl137_build_support.patch;patch=1 "
+
+# Fix-up headers for latest kernels and remove bogus CROSS_COMPILE configuration
+
+do_configure_prepend() {
+
+ # asm/page.h is gone with linux-libc-headers 2.6.31.
+ # We can safely sed it out since it has been empty for the past 2 years
+ sed -i /page.h/d ${S}/dsplink/gpp/src/api/Linux/drv_api.c || true
+
+ # Makefile passes hardcoded CROSS_COMPILE - rename so this doesnt get passed to kbuild
+ sed -i -e s:CROSS_COMPILE:BOGUS_CROSS_COMPILE:g ${S}/dsplink/gpp/src/Rules.mk
+}
+
# Cheat a bit with includes
# SZ_1k = 0x00000400
# ../gpp/src/arch/OMAP3530/shmem/Linux/omap3530_phy_shmem.c:127: error: 'SZ_2K' undeclared (first use in this function)
@@ -18,4 +31,3 @@ do_compile_prepend() {
sed -i s:SZ_2K:0x00000800:g ${S}/dsplink/gpp/src/arch/OMAP3530/shmem/Linux/omap3530_phy_shmem.c
}
-