aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-06-28 17:01:05 +0100
committerKoen Kooi <koen@openembedded.org>2010-06-29 16:42:38 +0200
commit7d38ccd4bca54267f9d7042533ebe851e2a9b5b2 (patch)
tree0a62430907048ea9ed33b962a73c3974a646443d /recipes/ti
parent78c66a51b7a88e4106603a857199efeefdb05864 (diff)
downloadopenembedded-7d38ccd4bca54267f9d7042533ebe851e2a9b5b2.tar.gz
ti-audio-soc-example: Add DSP based audio pass-through example for OMAPL (v.1.00.00.02)
* v.1.00.00.02 * Recipes from Arnie/Brijesh * This example demonstrates passing audio data from ARM to DSP, sending the output PCM samples to the DSP side audio device driver (from BIOS PSP) * App builds both ARM and DSP side, using DSPLINK for IPC communications Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-audio-soc-example.inc74
-rw-r--r--recipes/ti/ti-audio-soc-example_1.00.00.02.bb6
-rw-r--r--recipes/ti/ti-paths.inc1
3 files changed, 81 insertions, 0 deletions
diff --git a/recipes/ti/ti-audio-soc-example.inc b/recipes/ti/ti-audio-soc-example.inc
new file mode 100644
index 0000000000..65566adbc5
--- /dev/null
+++ b/recipes/ti/ti-audio-soc-example.inc
@@ -0,0 +1,74 @@
+DESCRIPTION = "TI Audio Soc devices example"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/apps_processors/Audio_soc_example/1_00/index_FDS.html"
+SECTION = "devel"
+LICENSE = "TI BSD"
+
+require ti-paths.inc
+require ti-staging.inc
+
+COMPATIBLE_MACHINE = "(da830-omapl137-evm|da850-omapl138-evm)"
+
+PR = "r5"
+
+S = "${WORKDIR}/audio_soc_example_${PV}"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/apps_processors/Audio_soc_example/1_00/exports/audio_soc_example_${PV}.tar.gz;name=audiosoctarball"
+
+DEPENDS = "ti-cgt6x ti-xdctools ti-dspbios ti-biospsp ti-edma3lld ti-dsplink"
+DEPENDS += "virtual/kernel"
+
+PLATFORM_da830-omapl137-evm = "omapl137"
+PLATFORM_da850-omapl138-evm = "omapl138"
+
+BOARD_da830-omapl137-evm = "evmOMAPL137"
+BOARD_da850-omapl138-evm = "evmOMAPL138"
+
+do_compile() {
+ # Build gpp sample application
+ cd ${S}
+ make \
+ PLATFORM="${PLATFORM}" \
+ CSTOOL_DIR="${TOOLCHAIN_PATH}" \
+ CSTOOLS_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
+ LINUXKERNEL_INSTALL_DIR="{STAGING_KERNEL_DIR}" \
+ BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}" \
+ XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
+ CODEGEN_INSTALL_DIR="${CODEGEN_INSTALL_DIR}" \
+ LINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
+ BIOSPSP_INSTALL_DIR="${BIOSPSP_INSTALL_DIR}" \
+ EDMA3LLD_INSTALL_DIR="${EDMA3_LLD_INSTALL_DIR}" \
+ gpp
+
+ # Build dsp sample application
+ make \
+ PLATFORM="${PLATFORM}" \
+ CSTOOL_DIR="${TOOLCHAIN_PATH}" \
+ CSTOOLS_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
+ LINUXKERNEL_INSTALL_DIR="{STAGING_KERNEL_DIR}" \
+ BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}" \
+ XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
+ CODEGEN_INSTALL_DIR="${CODEGEN_INSTALL_DIR}" \
+ LINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
+ BIOSPSP_INSTALL_DIR="${BIOSPSP_INSTALL_DIR}" \
+ EDMA3LLD_INSTALL_DIR="${EDMA3_LLD_INSTALL_DIR}" \
+ dsp
+}
+
+
+do_install() {
+ install -d ${D}${AUDIO_SOC_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${AUDIO_SOC_INSTALL_DIR_RECIPE}
+
+ install -d ${D}/${installdir}/ti-audio-soc-example
+ cp -rf ${S}/gpp/${BOARD} ${D}/${installdir}/ti-audio-soc-example
+ cp -rf ${S}/data/* ${D}/${installdir}/ti-audio-soc-example
+
+ cp -rf ${S}/dsp/${BOARD}/Debug/audioSoc_dsp.out ${D}/${installdir}/ti-audio-soc-example/${BOARD}/Debug
+ cp -rf ${S}/dsp/${BOARD}/Debug/audioSoc_dsp.out ${D}/${installdir}/ti-audio-soc-example/${BOARD}/Release
+
+}
+
+FILES_${PN} = "${installdir}/ti-audio-soc-example/*"
+INSANE_SKIP_${PN} = "True"
+
+RRECOMMENDS_ti_audio-soc-example += "ti-dsplink-module"
diff --git a/recipes/ti/ti-audio-soc-example_1.00.00.02.bb b/recipes/ti/ti-audio-soc-example_1.00.00.02.bb
new file mode 100644
index 0000000000..e3c1ace231
--- /dev/null
+++ b/recipes/ti/ti-audio-soc-example_1.00.00.02.bb
@@ -0,0 +1,6 @@
+require ti-audio-soc-example.inc
+
+PV = "1_00_00_02"
+
+SRC_URI[audiosoctarball.md5sum] = "980fead72fbd5999c97d9ae2ffe5017a"
+SRC_URI[audiosoctarball.sha256sum] = "70dff0c4fa3a7d450d6939eacdc2b8a7fbae867778693d14dcccbbcfd039b0f5"
diff --git a/recipes/ti/ti-paths.inc b/recipes/ti/ti-paths.inc
index 86852eb535..27400a1abc 100644
--- a/recipes/ti/ti-paths.inc
+++ b/recipes/ti/ti-paths.inc
@@ -19,6 +19,7 @@ export CODEC_INSTALL_DIR_RECIPE = "${installdir}/ti-codecs-tree"
export DSPLIB_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-tree"
export DVSDK_DEMOS_INSTALL_DIR_RECIPE = "${installdir}/ti-dvsdk-demos-tree"
export BIOSPSP_INSTALL_DIR_RECIPE = "${installdir}/ti-biospsp-tree"
+export AUDIO_SOC_INSTALL_DIR_RECIPE = "${installdir}/ti-audio-soc-example-tree"
# This is where the tools will end up in staging provided PACKAGE_ARCH = ${MACHINE_ARCH} is set
export CODEGEN_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}${CODEGEN_INSTALL_DIR_RECIPE}"