aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2010-05-06 01:49:42 -0400
committerDenys Dmytriyenko <denis@denix.org>2010-05-06 01:49:42 -0400
commit8a0750d20931f366c87b87e54f6232ea620449fd (patch)
tree9509496e929694ce7aa84a75da54c4afb41a4155 /recipes/ti
parent819cd0db4df56c85a6fd91b063133f49476ca926 (diff)
downloadopenembedded-8a0750d20931f366c87b87e54f6232ea620449fd.tar.gz
am-benchmarks: add ARM Benchmarks dhry/whet-stone, linpack (from Arago)
Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/am-benchmarks_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/ti/am-benchmarks_svn.bb b/recipes/ti/am-benchmarks_svn.bb
new file mode 100644
index 0000000000..23e194683a
--- /dev/null
+++ b/recipes/ti/am-benchmarks_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "AM Benchmarks"
+HOMEPAGE = "https://gforge.ti.com/gf/project/am_benchmarks/"
+LICENSE = "BSD"
+SECTION = "system"
+PRIORITY = "optional"
+
+SRCREV = "27"
+PV = "1.0"
+PR = "r1+svnr${SRCPV}"
+
+INSANE_SKIP_${PN} = "True"
+
+SRC_URI = "svn://gforge.ti.com/svn/am_benchmarks/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+S = "${WORKDIR}/trunk"
+
+do_compile() {
+ # don't build debug version
+ touch debug
+ export CROSS_COMPILE=${TARGET_PREFIX}
+ make release
+}
+
+do_install() {
+ make DESTDIR=${D} install
+}