aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-17 10:30:06 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-17 10:30:06 +0200
commit90fc51ebe1c85b8c539dcb3a62e44933b74b1649 (patch)
tree48d0832df95e9fbbb0f846975118159df55d5ebf /recipes/ti
parentcd37fc611f2e5f9157933d2117c7f45daa46ed7c (diff)
downloadopenembedded-90fc51ebe1c85b8c539dcb3a62e44933b74b1649.tar.gz
ti-devshell: fix method conflict
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-devshell.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/ti/ti-devshell.bb b/recipes/ti/ti-devshell.bb
index 610a79ba52..3b9dcc8563 100644
--- a/recipes/ti/ti-devshell.bb
+++ b/recipes/ti/ti-devshell.bb
@@ -10,7 +10,7 @@ do_configure() {
:
}
-def devshell_emit_env(o, d, all=False, funcwhitelist=None):
+def tidevshell_emit_env(o, d, all=False, funcwhitelist=None):
"""Emits all items in the data store in a format such that it can be sourced by a shell."""
env = bb.data.keys(d)
@@ -41,7 +41,7 @@ python do_compile() {
f = open(shellfile, "w")
# emit variables and shell functions
- devshell_emit_env(f, d, False, ["die", "oe", "autotools_do_configure"])
+ tidevshell_emit_env(f, d, False, ["die", "oe", "autotools_do_configure"])
f.close()
}