aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorJeff Lance <jefflance01@gmail.com>2011-01-05 04:51:36 +0000
committerKoen Kooi <koen@openembedded.org>2011-01-05 09:23:54 +0100
commit918ac10ebc2df03d59ee33ac6605701d33405182 (patch)
tree5bbf29bc4151f712ab8dc97b051d241beeb996a6 /recipes/ti
parent596212da205d59d2c6d2a91cae3a1b7c8b659577 (diff)
downloadopenembedded-918ac10ebc2df03d59ee33ac6605701d33405182.tar.gz
am-benchmarks: add platform support and correct makefile
* Modify recipe name to include package version * add support for additional platforms am181x-evm and am180x-evm * Update the SRCREV * Fix pathname to Rules.make in each Makefile Signed-off-by: Jeff Lance <j-lance1@ti.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/am-benchmarks_1.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/ti/am-benchmarks_1.2.bb b/recipes/ti/am-benchmarks_1.2.bb
new file mode 100644
index 0000000000..88b38e71c3
--- /dev/null
+++ b/recipes/ti/am-benchmarks_1.2.bb
@@ -0,0 +1,36 @@
+#NOTE: This package is currently only supported for the Angstrom
+# distribution. Other distributions and toolchains may or
+# may not work.
+
+DESCRIPTION = "AM Benchmarks"
+HOMEPAGE = "https://gforge.ti.com/gf/project/am_benchmarks/"
+LICENSE = "BSD"
+SECTION = "system"
+PRIORITY = "optional"
+
+SRCREV = "58"
+PR = "r2+svnr${SRCPV}"
+
+COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x)"
+
+ARCHITECTURE_dm365 = "arm9"
+ARCHITECTURE_omapl138 = "arm9"
+ARCHITECTURE_omap3 = "cortex-a8"
+ARCHITECTURE_ti816x = "cortex-a8"
+
+INSANE_SKIP_${PN} = "True"
+
+SRC_URI = "svn://gforge.ti.com/svn/am_benchmarks/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+S = "${WORKDIR}/trunk/${ARCHITECTURE}"
+
+do_compile() {
+ # don't build debug version
+ touch debug
+ export CROSS_COMPILE=${TARGET_PREFIX}
+ make release
+}
+
+do_install() {
+ make DESTDIR=${D} install
+}