aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2010-05-10 17:56:15 -0500
committerDenys Dmytriyenko <denis@denix.org>2010-05-10 19:47:13 -0400
commitb0ccc12f3f1b8d8ec80e45c3ee08d5c0ae865dad (patch)
treeface3f598acbe019fe0bed6ba42f2694e624bce9 /recipes/ti
parentb8e5860405cae09dabbd98a8d2b12752db90a373 (diff)
downloadopenembedded-b0ccc12f3f1b8d8ec80e45c3ee08d5c0ae865dad.tar.gz
matrix-gui_svn: add init script for dm365-evm.
* use default Rotation to 0 degrees. * remove touch screen specific variables. Signed-off-by: Brijesh Singh <bksingh@ti.com> Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/ti')
-rwxr-xr-xrecipes/ti/matrix-gui/dm365-evm/init26
-rw-r--r--recipes/ti/matrix-gui_svn.bb2
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes/ti/matrix-gui/dm365-evm/init b/recipes/ti/matrix-gui/dm365-evm/init
new file mode 100755
index 0000000000..b0e56ffd32
--- /dev/null
+++ b/recipes/ti/matrix-gui/dm365-evm/init
@@ -0,0 +1,26 @@
+#! /bin/sh
+matrixgui="/usr/bin/matrix_gui"
+GUI_OPTS="-qws -geometry 720x480+0+10 -display transformed:Rot0 /usr/share/matrix/html/menu_main.html"
+
+test -x "$matrixgui" || exit 0
+
+case "$1" in
+ start)
+ # switch to component 480p mode
+ echo 480P-60 > /sys/class/davinci_display/ch0/mode
+ echo COMPONENT > /sys/class/davinci_display/ch0/output
+ echo -n "Starting Matrix GUI application"
+ start-stop-daemon --start --quiet --background --pidfile /var/run/matrix-gui.pid --exec $matrixgui -- $GUI_OPTS
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping Matrix GUI application"
+ start-stop-daemon --stop --quiet --pidfile /var/run/matrix-gui.pid
+ echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/matrix-gui {start|stop}"
+ exit 1
+esac
+
+exit 0
diff --git a/recipes/ti/matrix-gui_svn.bb b/recipes/ti/matrix-gui_svn.bb
index 5d0f08248e..34db1ca336 100644
--- a/recipes/ti/matrix-gui_svn.bb
+++ b/recipes/ti/matrix-gui_svn.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
SRCREV = "56"
PV = "1.0"
-PR = "r5+svnr${SRCPV}"
+PR = "r6+svnr${SRCPV}"
SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
file://init \