aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-15 20:06:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-21 20:28:50 -0700
commitcaa6067f7faf33200681c75843ce2e059cb1c0b4 (patch)
tree334e6f6ab9b6dea945d192cb73afda3b30dd218f /recipes/ti
parente84f4995e257e0505fb73432cbd2a9f53cdf074b (diff)
downloadopenembedded-caa6067f7faf33200681c75843ce2e059cb1c0b4.tar.gz
Various fixes for cp argument portability
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/files/dvsdk-rules/Makefile2
-rw-r--r--recipes/ti/gstreamer-ti.inc4
-rw-r--r--recipes/ti/ti-audio-soc-example.inc8
3 files changed, 7 insertions, 7 deletions
diff --git a/recipes/ti/files/dvsdk-rules/Makefile b/recipes/ti/files/dvsdk-rules/Makefile
index bc1eabf249..c3cd7ee5bc 100644
--- a/recipes/ti/files/dvsdk-rules/Makefile
+++ b/recipes/ti/files/dvsdk-rules/Makefile
@@ -245,7 +245,7 @@ install:
$(MAKE) -C $(DEMO_INSTALL_DIR)/$(PLATFORM) install
@echo Copying examples..
- @cp -rp examples/$(PLATFORM)/web $(EXEC_DIR)/
+ @cp -Rp examples/$(PLATFORM)/web $(EXEC_DIR)/
@cp -p examples/$(PLATFORM)/dvevmdemo $(EXEC_DIR)/
@echo Installing clips..
diff --git a/recipes/ti/gstreamer-ti.inc b/recipes/ti/gstreamer-ti.inc
index d9ae67f2a8..880bc729de 100644
--- a/recipes/ti/gstreamer-ti.inc
+++ b/recipes/ti/gstreamer-ti.inc
@@ -86,14 +86,14 @@ do_install_prepend () {
install -d ${D}/${installdir}/gst/${PLATFORM}
# copy gstreamer demo scripts
- cp -r ${WORKDIR}/gstreamer_ti/gstreamer_demo/shared ${D}/${installdir}/gst
+ cp -R ${WORKDIR}/gstreamer_ti/gstreamer_demo/shared ${D}/${installdir}/gst
# If we have loadmodules.sh in WORKDIR then give preference to this over
# the default gst-ti loadmdules.sh
if [ -f ${WORKDIR}/loadmodules.sh ]; then
cp ${WORKDIR}/loadmodules.sh ${D}/${installdir}/gst/${PLATFORM}
else
- cp -r ${WORKDIR}/gstreamer_ti/gstreamer_demo/${PLATFORM} ${D}/${installdir}/gst
+ cp -R ${WORKDIR}/gstreamer_ti/gstreamer_demo/${PLATFORM} ${D}/${installdir}/gst
fi
# delete .svn files
diff --git a/recipes/ti/ti-audio-soc-example.inc b/recipes/ti/ti-audio-soc-example.inc
index a3942ccbcc..5e37113c44 100644
--- a/recipes/ti/ti-audio-soc-example.inc
+++ b/recipes/ti/ti-audio-soc-example.inc
@@ -60,11 +60,11 @@ do_install() {
cp -pPrf ${S}/* ${D}${AUDIO_SOC_INSTALL_DIR_RECIPE}
install -d ${D}/${installdir}/ti-audio-soc-example
- cp -rf ${S}/gpp/${BOARD} ${D}/${installdir}/ti-audio-soc-example
- cp -rf ${S}/data/* ${D}/${installdir}/ti-audio-soc-example
+ cp -Rf ${S}/gpp/${BOARD} ${D}/${installdir}/ti-audio-soc-example
+ cp -Rf ${S}/data/* ${D}/${installdir}/ti-audio-soc-example
- cp -rf ${S}/dsp/${BOARD}/Debug/audioSoc_dsp.out ${D}/${installdir}/ti-audio-soc-example/${BOARD}/Debug
- cp -rf ${S}/dsp/${BOARD}/Debug/audioSoc_dsp.out ${D}/${installdir}/ti-audio-soc-example/${BOARD}/Release
+ cp -Rf ${S}/dsp/${BOARD}/Debug/audioSoc_dsp.out ${D}/${installdir}/ti-audio-soc-example/${BOARD}/Debug
+ cp -Rf ${S}/dsp/${BOARD}/Debug/audioSoc_dsp.out ${D}/${installdir}/ti-audio-soc-example/${BOARD}/Release
}