aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorMelissa Watkins <m-watkins@ti.com>2010-12-02 05:17:00 -0600
committerKoen Kooi <koen@openembedded.org>2010-12-04 12:53:59 +0100
commitcfd4a39d14e0d51ec9501febb447cb8bfaa82efc (patch)
treea964033e0595c1375cd0c8d0d80c0e360cc1d2d9 /recipes/ti
parente8d5610aa11f8283a7f1d8874eb21d9113a67669 (diff)
downloadopenembedded-cfd4a39d14e0d51ec9501febb447cb8bfaa82efc.tar.gz
ti-pru-sw-edma-driver: first addition of PRU sw edma driver
* Add PRU sw edma driver recipe for the omapl138 and am181x-evm machines This recipe builds and installs an edma driver module that supports the edma user space libraries built by the ti-pru-sw-edma-library recipe. Signed-off-by: Melissa Watkins <m-watkins@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb b/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
new file mode 100644
index 0000000000..e315f8ef0c
--- /dev/null
+++ b/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Builds eDMA module used by eDMA libraries for PRU sw example applications"
+HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
+LICENSE = "GPLv2"
+PR = "r0+svnr${SRCPV}"
+
+COMPATIBLE_MACHINE = "omapl138|am180x-evm|am181x-evm"
+
+SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+SRCREV = "18"
+S = "${WORKDIR}/trunk/peripheral_lib/edma_driver/module"
+
+inherit module
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru
+ install -m 0755 ${S}/edmautils.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/
+}
+
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru/edmautils.ko"