aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorMelissa Watkins <m-watkins@ti.com>2010-12-02 05:14:40 -0600
committerKoen Kooi <koen@openembedded.org>2010-12-04 12:54:00 +0100
commitf3a58927748f0aa2e25cc167fa91c605266f742c (patch)
tree1715688250f0d58660bd7a9cd178a940d73ea391 /recipes/ti
parent66dd7b35757353ef0afc91ce7e2c7f4d838c9832 (diff)
downloadopenembedded-f3a58927748f0aa2e25cc167fa91c605266f742c.tar.gz
ti-pru-sw-app-loader: first addition of PRU sw application loader recipe
* Add PRU sw application loader recipe for the omapl138 machines This recipe builds the PRU application loader that is used to load a binary to the PRU's memory and manage the code executed in the PRU from the user space. The library and include files from the application loader are staged for use by the ti-pru-sw-examples recipe. Details about the application loader can be found at: http://processors.wiki.ti.com/index.php/PRU_Linux_Application_Loader Signed-off-by: Melissa Watkins <m-watkins@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rwxr-xr-xrecipes/ti/ti-pru-sw-app-loader_1.00.00.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/ti/ti-pru-sw-app-loader_1.00.00.bb b/recipes/ti/ti-pru-sw-app-loader_1.00.00.bb
new file mode 100755
index 0000000000..013ae89382
--- /dev/null
+++ b/recipes/ti/ti-pru-sw-app-loader_1.00.00.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "PRU sw application loader"
+HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
+LICENSE = "BSD"
+RRECOMMENDS_${PN} = "kernel-module-uio-pru"
+PR = "r0+svnr${SRCPV}"
+
+COMPATIBLE_MACHINE = "omapl138|am180x-evm"
+
+SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+SRCREV = "18"
+S = "${WORKDIR}/trunk/app_loader"
+
+do_compile () {
+ make -C ${S}/interface
+}
+
+do_install () {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/include/* ${D}${includedir}
+ install -m 0644 ${S}/lib/* ${D}${libdir}
+}