aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorBrijesh Singh <a0270506@incredibles.(none)>2009-08-31 05:12:13 -0500
committerKoen Kooi <koen@openembedded.org>2009-09-01 10:12:31 +0200
commitec8b2b66c915309587078d7635910e6d41b4e81e (patch)
tree0d3b8e2b9e3e2a81108442babc867c042a741919 /recipes/ti
parent40dd422071b98b49229cf188fa9ddc0c714c8787 (diff)
downloadopenembedded-ec8b2b66c915309587078d7635910e6d41b4e81e.tar.gz
gstreamer-ti: merge updated patch from tracker and export CODEC_SERVER dir for the hard-coded server name
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/files/gstreamer-ti-tracker-824.patch38
-rw-r--r--recipes/ti/gstreamer-ti_svn.bb10
2 files changed, 38 insertions, 10 deletions
diff --git a/recipes/ti/files/gstreamer-ti-tracker-824.patch b/recipes/ti/files/gstreamer-ti-tracker-824.patch
index 852e60adbc..634fa4aaf6 100644
--- a/recipes/ti/files/gstreamer-ti-tracker-824.patch
+++ b/recipes/ti/files/gstreamer-ti-tracker-824.patch
@@ -1,6 +1,15 @@
-diff -uNr ticodecplugin/src/gstticodecplugin_omap3530.cfg ticodecplugin.new/src/gstticodecplugin_omap3530.cfg
---- ticodecplugin/src/gstticodecplugin_omap3530.cfg 2009-06-10 17:29:59.000000000 -0500
-+++ ticodecplugin.new/src/gstticodecplugin_omap3530.cfg 2009-08-07 16:17:24.000000000 -0500
+--- ticodecplugin/ChangeLog
++++ ticodecplugin.new/ChangeLog
+@@ -1,3 +1,7 @@
++2009-08-14 Don Darling, Texas Instruments, Inc.
++ * src/{gstticodecplugin_omap3530.cfg,gstticodecs_omap3530.c}:
++ Update OMAP3530 Support to use DVSDK 3.00.00.40.
++
+ 2009-07-28 Brijesh Singh, Texas Instruments, Inc.
+ * src/{gstticircbuffer.c}:
+ Fix potential memory leak in circular buffer when accel framecopy flag is
+--- ticodecplugin/src/gstticodecplugin_omap3530.cfg
++++ ticodecplugin.new/src/gstticodecplugin_omap3530.cfg
@@ -12,8 +12,6 @@
*
*/
@@ -10,7 +19,7 @@ diff -uNr ticodecplugin/src/gstticodecplugin_omap3530.cfg ticodecplugin.new/src/
/* Load the Codec Engine 'Operating System Abstraction Layer' */
var osalGlobal = xdc.useModule('ti.sdo.ce.osal.Global');
-@@ -27,21 +25,15 @@
+@@ -27,31 +25,20 @@ ipc.commType = ipc.COMM_DSPLINK;
/*
* ======== Engine Configuration ========
*/
@@ -31,6 +40,19 @@ diff -uNr ticodecplugin/src/gstticodecplugin_omap3530.cfg ticodecplugin.new/src/
+ "ti.sdo.server.cs"
);
+-var encpath = "" + java.lang.System.getenv("ENCODE_COMBO");
+-if (encpath != "" && encpath != "null") {
+- encEngine.server = java.lang.System.getenv("ENCODE_COMBO");
+-}
+-
+-var decpath = "" + java.lang.System.getenv("DECODE_COMBO");
+-if (decpath != "" && decpath != "null") {
+- decEngine.server = java.lang.System.getenv("DECODE_COMBO");
++var combopath = "" + java.lang.System.getenv("CODEC_SERVER");
++if (combopath != "" && combopath != "null") {
++ demoEngine.server = java.lang.System.getenv("CODEC_SERVER");
+ }
+
/* Load support for the DMAI module */
var DMAI = xdc.loadPackage('ti.sdo.dmai');
@@ -39,9 +61,8 @@ diff -uNr ticodecplugin/src/gstticodecplugin_omap3530.cfg ticodecplugin.new/src/
-var SDMA = xdc.useModule("ti.sdo.linuxutils.sdma.SDMA");
+var SCPY = xdc.useModule('ti.sdo.fc.scpy.SCPY');
+var SDMA = xdc.useModule('ti.sdo.linuxutils.sdma.SDMA');
-diff -uNr ticodecplugin/src/gstticodecs_omap3530.c ticodecplugin.new/src/gstticodecs_omap3530.c
---- ticodecplugin/src/gstticodecs_omap3530.c 2009-06-10 17:29:59.000000000 -0500
-+++ ticodecplugin.new/src/gstticodecs_omap3530.c 2009-08-07 16:17:24.000000000 -0500
+--- ticodecplugin/src/gstticodecs_omap3530.c
++++ ticodecplugin.new/src/gstticodecs_omap3530.c
@@ -22,8 +22,7 @@
#include "gstticodecs.h"
@@ -52,7 +73,7 @@ diff -uNr ticodecplugin/src/gstticodecs_omap3530.c ticodecplugin.new/src/gsttico
/* NULL terminated list of speech decoders in the engine to use in the demo */
GstTICodec gst_ticodec_codecs[] = {
-@@ -32,59 +31,55 @@
+@@ -32,59 +31,55 @@ GstTICodec gst_ticodec_codecs[] = {
{
"AAC Audio Decoder", /* String name of codec used by plugin */
"aachedec", /* String name of codec used by CE */
@@ -123,3 +144,4 @@ diff -uNr ticodecplugin/src/gstticodecs_omap3530.c ticodecplugin.new/src/gsttico
},
{ NULL }
+
diff --git a/recipes/ti/gstreamer-ti_svn.bb b/recipes/ti/gstreamer-ti_svn.bb
index 7d13c7186a..59f7046bac 100644
--- a/recipes/ti/gstreamer-ti_svn.bb
+++ b/recipes/ti/gstreamer-ti_svn.bb
@@ -7,13 +7,13 @@ inherit autotools
DEPENDS = "ti-dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly"
# Fetch source from svn repo
-SRCREV = "285"
+SRCREV = "331"
SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=https;user=anonymous;pswd='' \
file://gstreamer-ti-tracker-824.patch;patch=1 \
"
# Again, no '.' in PWD allowed :(
-PR = "r28"
+PR = "r32"
PV = "svnr${SRCREV}"
S = "${WORKDIR}/gstreamer_ti/ti_build/ticodecplugin"
@@ -36,6 +36,12 @@ CPPFLAGS_append = " -DPlatform_${PLATFORM}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+# export codec combo (or server) locations
+export HMJCP_COMBO = "${installdir}/codec-combo/hmjcp.accel"
+export CODEC_SERVER = "${installdir}/codec-combo/cs.x64P"
+export ENCODE_COMBO = "${installdir}/codec-combo/encodeCombo.x64P"
+export DECODE_COMBO = "${installdir}/codec-combo/decodeCombo.x64P"
+
do_install_prepend () {
# install gstreamer demo scripts
install -d ${D}/${installdir}/gst