aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tinc/tinc_1.0.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tinc/tinc_1.0.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tinc/tinc_1.0.2.bb')
-rw-r--r--recipes/tinc/tinc_1.0.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/tinc/tinc_1.0.2.bb b/recipes/tinc/tinc_1.0.2.bb
new file mode 100644
index 0000000000..26a97ed38a
--- /dev/null
+++ b/recipes/tinc/tinc_1.0.2.bb
@@ -0,0 +1,31 @@
+SECTION = "console/network"
+DESCRIPTION ="tinc is a Virtual Private Network (VPN) daemon"
+HOMEPAGE = "http://www.tinc-vpn.org/"
+LICENSE = "GPLv2"
+PR = "r1"
+
+SRC_URI="http://www.tinc-vpn.org/packages/tinc-1.0.2.tar.gz \
+ file://mtu-vlan.diff;patch=1 \
+ file://public-key-fix.diff;patch=1 \
+ file://init"
+
+DEPENDS = "openssl lzo zlib"
+RRECOMMENDS = "kernel-module-tun"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-maintainer-mode --disable-tracing"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/tinc
+}