aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tn5250
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tn5250
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tn5250')
-rw-r--r--recipes/tn5250/tn5250-0.16.5/compile.patch16
-rw-r--r--recipes/tn5250/tn5250_0.16.5.bb22
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/tn5250/tn5250-0.16.5/compile.patch b/recipes/tn5250/tn5250-0.16.5/compile.patch
new file mode 100644
index 0000000000..8b94d80b1d
--- /dev/null
+++ b/recipes/tn5250/tn5250-0.16.5/compile.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tn5250-0.16.5/src/tn5250.c~compile
++++ tn5250-0.16.5/src/tn5250.c
+@@ -179,7 +179,7 @@
+ tn5250 [options] HOST[:PORT]\n");
+ #ifdef HAVE_LIBSSL
+ printf("\
+- To connect using ssl prefix HOST with 'ssl:'. Example:
++ To connect using ssl prefix HOST with 'ssl:'. Example:\n\
+ tn5250 +ssl_verify_server ssl:as400.example.com\n");
+ #endif
+ printf ("\n\
diff --git a/recipes/tn5250/tn5250_0.16.5.bb b/recipes/tn5250/tn5250_0.16.5.bb
new file mode 100644
index 0000000000..5e12dadeb1
--- /dev/null
+++ b/recipes/tn5250/tn5250_0.16.5.bb
@@ -0,0 +1,22 @@
+SECTION = "console/network"
+DESCRIPTION = "tn5250 is a 5250 terminal emulator, used for connecting \
+to IBM's AS/400 (now known as eServer iSeries) midrange computers."
+HOMEPAGE = "http://tn5250.sourceforge.net/"
+LICENSE = "LGPL"
+DEPENDS = "ncurses openssl"
+PR ="r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tn5250/tn5250-${PV}.tar.gz \
+ file://compile.patch;patch=1"
+
+inherit autotools
+
+PACKAGES = "${PN}-dbg lib5250-0 tn5250-dev tn5250-doc tn5250"
+FILES_${PN} = "${bindir}/tn5250"
+FILES_lib5250-0 = "${libdir}/lib*.so.*"
+AUTO_LIBNAME_PKGS = "lib5250"
+
+do_stage() {
+ autotools_stage_includes
+ oe_libinstall -so -a -C src lib5250 ${STAGING_LIBDIR}
+}