aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/toscoterm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/toscoterm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/toscoterm')
-rw-r--r--recipes/toscoterm/toscoterm_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/toscoterm/toscoterm_git.bb b/recipes/toscoterm/toscoterm_git.bb
new file mode 100644
index 0000000000..9826c9e9d1
--- /dev/null
+++ b/recipes/toscoterm/toscoterm_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A very small and simple terminal emulator"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+DEPENDS = "vte"
+HOMEPAGE = "https://projetos.ossystems.com.br/projects/show/toscoterm"
+PV = "0.0+gitr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "git://projetos.ossystems.com.br/git/toscoterm.git;protocol=git"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake \
+ CC="${CC}" \
+ CFLAGS="${CFLAGS} `pkg-config --cflags gtk+-2.0` `pkg-config --cflags vte`" \
+ LDFLAGS="${LDFLAGS} `pkg-config --libs gtk+-2.0` `pkg-config --libs vte`"
+}
+
+do_install() {
+ oe_runmake PREFIX="/usr" DESTDIR="${D}" install
+}