aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/totem
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-11 18:26:49 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-11 20:41:39 +0100
commit28d2a94901ef7e2e56e960297e576bc8fd1b7fe1 (patch)
tree2c34ead1261828747fcc3815689b2f6e5c370fbe /recipes/totem
parent397c683395ad0d65f639d29ce49bdfdcf571c1d6 (diff)
downloadopenembedded-28d2a94901ef7e2e56e960297e576bc8fd1b7fe1.tar.gz
totem: add 2.28.5
Diffstat (limited to 'recipes/totem')
-rw-r--r--recipes/totem/totem-2.28.5/gst-detect.diff46
-rw-r--r--recipes/totem/totem_2.28.5.bb73
2 files changed, 119 insertions, 0 deletions
diff --git a/recipes/totem/totem-2.28.5/gst-detect.diff b/recipes/totem/totem-2.28.5/gst-detect.diff
new file mode 100644
index 0000000000..6ac4455ad0
--- /dev/null
+++ b/recipes/totem/totem-2.28.5/gst-detect.diff
@@ -0,0 +1,46 @@
+--- /tmp/configure.in 2009-10-21 11:43:19.000000000 +0200
++++ totem-2.28.1/configure.in 2009-10-21 11:47:21.000000000 +0200
+@@ -110,10 +110,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 tool 'gst-inspect-0.10'.
+- It should be part of gstreamer-0_10-utils. Please install it.
+- ])
+ fi
+
+ dnl Check for elements from gst-plugins-base
+@@ -124,10 +120,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$base_element'.
+- It should be part of gst-plugins-base. Please install it.
+- ])
+ fi
+ done
+
+@@ -139,10 +131,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$good_element'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
+ fi
+ done
+
+@@ -570,10 +558,6 @@
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin 'souphttpsrc'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
+ fi
+ ;;
+ esac
diff --git a/recipes/totem/totem_2.28.5.bb b/recipes/totem/totem_2.28.5.bb
new file mode 100644
index 0000000000..45fb607325
--- /dev/null
+++ b/recipes/totem/totem_2.28.5.bb
@@ -0,0 +1,73 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = " libunique libgdata totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS_${PN} += "iso-codes"
+RRECOMMENDS_${PN} += "gst-plugin-playbin \
+ gst-plugin-gconfelements \
+ gst-plugin-decodebin \
+ gst-plugin-decodebin2 \
+ gst-ffmpeg \
+ gst-plugin-audioresample \
+ gst-plugin-ximagesink \
+ gst-plugin-xvimagesink \
+ gst-plugin-alsa \
+ gst-plugin-avi \
+ gst-plugin-ffmpegcolorspace \
+ gst-plugin-flvdemux \
+ gst-plugin-nuvdemux \
+ gst-plugin-videoscale \
+ gst-plugin-a52dec \
+ gst-plugin-mpegaudioparse \
+ gst-plugin-ossaudio \
+ gst-plugin-pulse \
+ gst-plugin-autodetect \
+ totem-plugin-youtube totem-plugin-thumbnail totem-plugin-dbus totem-plugin-screensaver"
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+EXTRA_OECONF=" --disable-schemas-install \
+ --enable-gtk \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-gstreamer \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --disable-vala \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+ sed -i -e s:PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION":PYTHON_CFLAGS="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g ${S}/configure.in
+}
+
+PACKAGES_DYNAMIC += " totem-plugin-* "
+
+python populate_packages_prepend () {
+ totem_libdir = bb.data.expand('${libdir}/totem/plugins/', d)
+
+ do_split_packages(d, totem_libdir, '^(.*)', 'totem-plugin-%s', 'totem plugin for %s', allow_dirs=True, extra_depends='')
+}
+
+FILES_${PN} = "${bindir}/* ${sysconfdir} ${libdir}/lib*.so.* ${libexecdir} ${datadir}/icons ${datadir}/totem ${datadir}/applications \
+"
+
+PACKAGES =+ "totem-nautilus-extension totem-browser-plugin-dbg totem-browser-plugin"
+
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_${PN}-dev += "${libdir}/totem/plugins/*/*a"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"
+
+FILES_totem-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so"
+
+
+