aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/treecc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/treecc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/treecc')
-rw-r--r--recipes/treecc/treecc-0.3.6/dont-make-in-examples.patch12
-rw-r--r--recipes/treecc/treecc-native_0.3.6.bb11
-rw-r--r--recipes/treecc/treecc_0.3.6.bb11
3 files changed, 34 insertions, 0 deletions
diff --git a/recipes/treecc/treecc-0.3.6/dont-make-in-examples.patch b/recipes/treecc/treecc-0.3.6/dont-make-in-examples.patch
new file mode 100644
index 0000000000..b722552565
--- /dev/null
+++ b/recipes/treecc/treecc-0.3.6/dont-make-in-examples.patch
@@ -0,0 +1,12 @@
+diff -Nurd treecc-0.3.6.orig/Makefile.in treecc-0.3.6/Makefile.in
+--- treecc-0.3.6.orig/Makefile.in 2005-01-15 15:16:06.000000000 -0800
++++ treecc-0.3.6/Makefile.in 2005-08-12 15:36:24.481697542 -0700
+@@ -77,7 +77,7 @@
+ VERSION = @VERSION@
+ YACC = @YACC@
+
+-SUBDIRS = . etc doc tests examples
++SUBDIRS = . etc doc tests
+
+ bin_PROGRAMS = treecc
+ noinst_LIBRARIES = libtreecc.a
diff --git a/recipes/treecc/treecc-native_0.3.6.bb b/recipes/treecc/treecc-native_0.3.6.bb
new file mode 100644
index 0000000000..bcdd2e7677
--- /dev/null
+++ b/recipes/treecc/treecc-native_0.3.6.bb
@@ -0,0 +1,11 @@
+require treecc_${PV}.bb
+SECTION = "devel"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/treecc-${PV}"
+S = "${WORKDIR}/treecc-${PV}"
+
+inherit native autotools
+
+do_stage() {
+ rm -f ${STAGING_BINDIR}/treecc
+ install -m 0755 treecc ${STAGING_BINDIR}/
+}
diff --git a/recipes/treecc/treecc_0.3.6.bb b/recipes/treecc/treecc_0.3.6.bb
new file mode 100644
index 0000000000..e54beb4810
--- /dev/null
+++ b/recipes/treecc/treecc_0.3.6.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Tree Compiler-Compiler from dotGNU"
+SECTION = "devel"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.southern-storm.com.au/treecc.html"
+PRIORITY = "optional"
+
+SRC_URI = "http://www.southern-storm.com.au/download/treecc-${PV}.tar.gz \
+ file://dont-make-in-examples.patch;patch=1"
+
+inherit autotools
+