aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tremor
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-09-29 10:36:27 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-06 15:31:39 -0700
commit0d5594975557c6eea0ccdef427a200e9cf71e4e8 (patch)
tree7880aeb82a3b7a7a6a1507240bc1083cc5c52503 /recipes/tremor
parentbb2ba59d81dc96919cb95f869ec288b78816f63b (diff)
downloadopenembedded-0d5594975557c6eea0ccdef427a200e9cf71e4e8.tar.gz
tremor-20041119: Add pkgconfig file, provide libvorbisidec
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/tremor')
-rw-r--r--recipes/tremor/tremor/pkgconfig.patch22
-rw-r--r--recipes/tremor/tremor_20041119.bb9
2 files changed, 28 insertions, 3 deletions
diff --git a/recipes/tremor/tremor/pkgconfig.patch b/recipes/tremor/tremor/pkgconfig.patch
new file mode 100644
index 0000000000..f864cb8de1
--- /dev/null
+++ b/recipes/tremor/tremor/pkgconfig.patch
@@ -0,0 +1,22 @@
+--- Tremor/configure.in 2006-09-03 01:19:30.000000000 +0200
++++ Tremor-fixed/configure.in 2006-09-03 12:13:33.339593728 +0200
+@@ -106,4 +106,4 @@
+ AC_SUBST(DEBUG)
+ AC_SUBST(PROFILE)
+
+-AC_OUTPUT(Makefile)
++AC_OUTPUT([Makefile vorbisidec.pc])
+--- Tremor/vorbisidec.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ Tremor-fixed/vorbisidec.pc.in 2006-09-03 12:16:38.313473424 +0200
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: vorbisidec
++Description: Vorbis audio decoder
++Requires:
++Version: 20041119
++Libs: -L${libdir} -lvorbisidec
++Cflags: -I${includedir}
diff --git a/recipes/tremor/tremor_20041119.bb b/recipes/tremor/tremor_20041119.bb
index 889b981ae9..42155abf3d 100644
--- a/recipes/tremor/tremor_20041119.bb
+++ b/recipes/tremor/tremor_20041119.bb
@@ -4,16 +4,19 @@ DEPENDS = "libogg"
DESCRIPTION = "tremor is a fixed point implementation of the vorbis codec."
LICENSE = "BSD"
SRCDATE = "${PV}"
-PR = "r1"
+PR = "r2"
# tremor makes heavy use of non-thumb-compatible inline asm.
ARM_INSTRUCTION_SET = "arm"
-SRC_URI = "svn://svn.xiph.org/trunk;module=Tremor;rev=4573;proto=http"
+PROVIDES += "libvorbisidec"
+
+SRC_URI = "svn://svn.xiph.org/trunk;module=Tremor;rev=4573;proto=http \
+ file://pkgconfig.patch"
S = "${WORKDIR}/Tremor"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_OECONF=" --enable-shared --disable-rpath "