aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ttf-fonts
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/ttf-fonts
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ttf-fonts')
-rw-r--r--recipes/ttf-fonts/ttf-dejavu_2.23.bb2
-rw-r--r--recipes/ttf-fonts/ttf.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/ttf-fonts/ttf-dejavu_2.23.bb b/recipes/ttf-fonts/ttf-dejavu_2.23.bb
index 0c4bd41345..931b9e69ba 100644
--- a/recipes/ttf-fonts/ttf-dejavu_2.23.bb
+++ b/recipes/ttf-fonts/ttf-dejavu_2.23.bb
@@ -3,7 +3,7 @@ require ttf.inc
DESCRIPTION = "DejaVu font - TTF Edition"
HOMEPAGE = "http://dejavu.sourceforge.net/wiki/"
LICENSE = "Bitstream Vera"
-RDEPENDS = "ttf-dejavu-common"
+RDEPENDS_${PN} = "ttf-dejavu-common"
RDEPENDS_ttf-dejavu-common = ""
PR = "r2"
diff --git a/recipes/ttf-fonts/ttf.inc b/recipes/ttf-fonts/ttf.inc
index 3c04f1b320..101d11b59a 100644
--- a/recipes/ttf-fonts/ttf.inc
+++ b/recipes/ttf-fonts/ttf.inc
@@ -1,7 +1,7 @@
DESCRIPTION ?= "TrueType font package ${PN}"
SECTION = "fonts"
PRIORITY = "optional"
-RRECOMMENDS += "font-update-common"
+RRECOMMENDS_${PN} += "font-update-common"
# we don't need a compiler nor a c library for these fonts
INHIBIT_DEFAULT_DEPS = "1"