summaryrefslogtreecommitdiffstats
path: root/recipes/ttyrec
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ttyrec
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ttyrec')
-rw-r--r--recipes/ttyrec/files/Makefile.patch8
-rw-r--r--recipes/ttyrec/ttyrec_1.0.8.bb41
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes/ttyrec/files/Makefile.patch b/recipes/ttyrec/files/Makefile.patch
new file mode 100644
index 0000000000..4c2f5774af
--- /dev/null
+++ b/recipes/ttyrec/files/Makefile.patch
@@ -0,0 +1,8 @@
+--- ttyrec-1.0.8/Makefile.orig 2007-04-03 02:08:25.000000000 +0000
++++ ttyrec-1.0.8/Makefile 2007-04-03 02:08:42.000000000 +0000
+@@ -1,5 +1,3 @@
+-CC = gcc
+-CFLAGS = -O2
+ VERSION = 1.0.8
+
+ TARGET = ttyrec ttyplay ttytime
diff --git a/recipes/ttyrec/ttyrec_1.0.8.bb b/recipes/ttyrec/ttyrec_1.0.8.bb
new file mode 100644
index 0000000000..bf58f245cb
--- /dev/null
+++ b/recipes/ttyrec/ttyrec_1.0.8.bb
@@ -0,0 +1,41 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2007
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: ttyrec_1.0.8.bb
+# Date: 20070403 (YMD)
+
+DESCRIPTION = "ttyrec is a tty recorder. Recorded data can be played back with the included ttyplay command."
+HOMEPAGE = "http://0xcc.net/ttyrec/index.html.en"
+
+######################################################################################
+
+PR = "r0"
+
+######################################################################################
+
+SRC_URI = "http://0xcc.net/ttyrec/${PN}-${PV}.tar.gz \
+ file://Makefile.patch;patch=1"
+
+######################################################################################
+
+inherit autotools
+
+######################################################################################
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+######################################################################################
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -d ${D}/usr/share/man/man1
+
+ for binary in ttyrec ttyplay ttytime
+ do
+ install -m 0755 ${S}/${binary} ${D}/usr/bin/
+ install -m 0644 ${S}/${binary}.1 ${D}/usr/share/man/man1
+ done
+}