aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tximage/tximage_0.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tximage/tximage_0.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tximage/tximage_0.2.bb')
-rw-r--r--recipes/tximage/tximage_0.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/tximage/tximage_0.2.bb b/recipes/tximage/tximage_0.2.bb
new file mode 100644
index 0000000000..1911e4fb51
--- /dev/null
+++ b/recipes/tximage/tximage_0.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Tx Image Viewer"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://community.zaurus.com/projects/tximage/"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/mirror/tximage-${PV}.tar.gz \
+ file://gcc3.patch;patch=1 \
+ file://gcc4.patch;patch=1"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/bin
+ install -D -m 755 tximage ${D}${palmtopdir}/bin/tximage
+ install -D -m 644 imageviewer.desktop ${D}${palmtopdir}/apps/Applications/tximage.desktop
+ cp -pPR tximage.png ${D}${palmtopdir}/pics/
+}