aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/files
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-11 09:17:13 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-11 09:17:59 +0100
commitf5b48eb44a38a1e6fff28bd92de0591e2b00d073 (patch)
treec2fe94cb22fbb327506949c19e190f926cbf166e /recipes/u-boot/files
parentbc68929ceaa163e27d8e9860e2f816065c14d0fa (diff)
downloadopenembedded-f5b48eb44a38a1e6fff28bd92de0591e2b00d073.tar.gz
Revert "u-boot_git.bb: Do not apply u-boot-remove-inline-of-weak-functions.patch"
The weak inline patch is being applied to machines that already have that in their tree and it isn't boot tested Since bootloaders are critical or machines to work this patch needs to go and is only allowed back after being boot tested on affected machines. This reverts commit 6795b4bf1ed4074fd83703c19828f91492c6507f. This reverts commit 40914431d5c2426945fe5f206d86c99222ace54b.
Diffstat (limited to 'recipes/u-boot/files')
-rw-r--r--recipes/u-boot/files/u-boot-remove-inline-of-weak-functions.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/recipes/u-boot/files/u-boot-remove-inline-of-weak-functions.patch b/recipes/u-boot/files/u-boot-remove-inline-of-weak-functions.patch
deleted file mode 100644
index ea0c2d74ff..0000000000
--- a/recipes/u-boot/files/u-boot-remove-inline-of-weak-functions.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Remove 'inline' keyword of functions with weak attribution
-
-* gcc-4.4 complains about 'inline' functions with 'weak' attribution
-Index: git/lib_arm/board.c
-===================================================================
---- git.orig/lib_arm/board.c 2010-01-26 04:56:38.000000000 +0800
-+++ git/lib_arm/board.c 2010-02-02 19:31:42.000000000 +0800
-@@ -123,19 +123,19 @@
- * May be supplied by boards if desired
- */
- void inline __coloured_LED_init (void) {}
--void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
-+void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
- void inline __red_LED_on (void) {}
--void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
-+void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
- void inline __red_LED_off(void) {}
--void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
-+void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
- void inline __green_LED_on(void) {}
--void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
-+void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
- void inline __green_LED_off(void) {}
--void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
-+void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
- void inline __yellow_LED_on(void) {}
--void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
-+void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
- void inline __yellow_LED_off(void) {}
--void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
-+void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
-
- /************************************************************************
- * Init Utilities *
-Index: git/common/main.c
-===================================================================
---- git.orig/common/main.c 2010-02-02 19:32:17.000000000 +0800
-+++ git/common/main.c 2010-02-02 19:32:21.000000000 +0800
-@@ -48,7 +48,7 @@
- * Board-specific Platform code can reimplement show_boot_progress () if needed
- */
- void inline __show_boot_progress (int val) {}
--void inline show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
-+void show_boot_progress (int val) __attribute__((weak, alias("__show_boot_progress")));
-
- #if defined(CONFIG_BOOT_RETRY_TIME) && defined(CONFIG_RESET_TO_RETRY)
- extern int do_reset (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[]); /* for do_reset() prototype */