aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
commit293b05335ab540c4c8402e0a5caf2886b786a318 (patch)
tree11e5a7c2dce338058f150e08d1ff47c9d4d8eccd /recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch
parent1ee2156592ba17f64f3c9b8970285a259730b871 (diff)
parente9aacc4ce4784c91cb4908145b8fb7b3ec8aa6e0 (diff)
downloadopenembedded-293b05335ab540c4c8402e0a5caf2886b786a318.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/testing2010
Conflicts: recipes/linux/linux-openmoko-devel_git.bb recipes/openmoko-3rdparty/pisi_0.5.2.bb recipes/openmoko-3rdparty/pisi_0.5.3.bb recipes/openmoko-3rdparty/pisi_0.5.bb recipes/uclibc/uclibc_nptl.bb
Diffstat (limited to 'recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch')
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch b/recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch
new file mode 100644
index 0000000000..de3b4845b0
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0006-OMAP3-add-mpurate-boot-arg-for-overo-and-beagle.patch
@@ -0,0 +1,70 @@
+From 1b082bb4a8ba5b7bee727baf3cd048e1785c8abd Mon Sep 17 00:00:00 2001
+From: Steve Sakoman <steve@sakoman.com>
+Date: Wed, 3 Feb 2010 14:39:14 -0800
+Subject: [PATCH 06/37] OMAP3: add mpurate boot arg for overo and beagle
+
+allows one to set the omap clock rate via "setenv mpurate 720" for example
+---
+ include/configs/omap3_beagle.h | 3 +++
+ include/configs/omap3_overo.h | 3 +++
+ 2 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
+index 87e3dd0..ce347cd 100644
+--- a/include/configs/omap3_beagle.h
++++ b/include/configs/omap3_beagle.h
+@@ -182,6 +182,7 @@
+ "loadaddr=0x82000000\0" \
+ "usbtty=cdc_acm\0" \
+ "console=ttyS2,115200n8\0" \
++ "mpurate=500\0" \
+ "vram=12M\0" \
+ "dvimode=1024x768MR-16@60\0" \
+ "defaultdisplay=dvi\0" \
+@@ -190,6 +191,7 @@
+ "nandroot=/dev/mtdblock4 rw\0" \
+ "nandrootfstype=jffs2\0" \
+ "mmcargs=setenv bootargs console=${console} " \
++ "mpurate=${mpurate} " \
+ "vram=${vram} " \
+ "omapfb.mode=dvi:${dvimode} " \
+ "omapfb.debug=y " \
+@@ -197,6 +199,7 @@
+ "root=${mmcroot} " \
+ "rootfstype=${mmcrootfstype}\0" \
+ "nandargs=setenv bootargs console=${console} " \
++ "mpurate=${mpurate} " \
+ "vram=${vram} " \
+ "omapfb.mode=dvi:${dvimode} " \
+ "omapfb.debug=y " \
+diff --git a/include/configs/omap3_overo.h b/include/configs/omap3_overo.h
+index 0d24758..295cce6 100644
+--- a/include/configs/omap3_overo.h
++++ b/include/configs/omap3_overo.h
+@@ -152,6 +152,7 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x82000000\0" \
+ "console=ttyS2,115200n8\0" \
++ "mpurate=500\0" \
+ "vram=12M\0" \
+ "dvimode=1024x768MR-16@60\0" \
+ "defaultdisplay=dvi\0" \
+@@ -160,6 +161,7 @@
+ "nandroot=/dev/mtdblock4 rw\0" \
+ "nandrootfstype=jffs2\0" \
+ "mmcargs=setenv bootargs console=${console} " \
++ "mpurate=${mpurate} " \
+ "vram=${vram} " \
+ "omapfb.mode=dvi:${dvimode} " \
+ "omapfb.debug=y " \
+@@ -167,6 +169,7 @@
+ "root=${mmcroot} " \
+ "rootfstype=${mmcrootfstype}\0" \
+ "nandargs=setenv bootargs console=${console} " \
++ "mpurate=${mpurate} " \
+ "vram=${vram} " \
+ "omapfb.mode=dvi:${dvimode} " \
+ "omapfb.debug=y " \
+--
+1.6.6.1
+